Nginx 502 Bad Gateway Errors

Just hoping that someone here with nginx experience can help me with this issue. I installed nginx and php-fastcgi with xcache on my ubuntu server and all seemed to be working well. Speed was almost 2x faster.

I am running into errors though in certain parts of WP. It returns a 502 Bad Gateway error when you try to publish or save a post or page. The actual post is saved, but it seems on the redirect after saving that nginx throws the error. It also happens when saving the Settings->General page on blogs.

Also occasionally the frontpage of the Nelo theme is not returned in it's entirety. Half of the HTML is served then the connection is closed with a 200 successful header. That issue can be temporarily fixed by restarting the php-cgi processes.

Checking my error logs shows a lot of errors like this:
2010/03/19 05:00:20 [error] 20064#0: *42360 readv() failed (104: Connection reset by peer) while reading upstream, client: 207.46.13.44, server: missionsplace.com, request: "GET /tag/vision/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "zmotion.missionsplace.com"
2010/03/19 05:01:02 [error] 20064#0: *42364 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 71.202.206.59, server: missionsplace.com, request: "POST /wp-admin/post.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "test.missionsplace.com", referrer: "http://test.missionsplace.com/wp-admin/post.php?action=edit&post=114"

Anyone run into anything similar? Can't find anything on Google similar to this issue.