No admin users on Membership Premium

Hi guys,

I’ve been having trouble with user levels in the Membership plugin.

After altering access levels, I locked myself out of standard Admin-level access to the Dashboard etc even though I’m a Membership Admin user.

Checking the Membership Admins under the plugin options I get this message:

“There are no Admin users – something may have gone wrong.”

I tried uninstalling and reinstalling. I’ve been working on it all night actually.

Any thoughts?

TKs,

Craig K.

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Try sticking this in your wp-config.php file:

    define( 'MEMBERSHIP_MASTER_ADMIN', 'USERNAME');

    Change the username to your own. That may sort it. If not, in your admin access is wrong in the DB, you could also try:

    1. login to your database with phpmyadmin if you have it.
    2. Find your admin user, get the user_id for it - probably 1.
    3. Go to the wp_usermeta table and look for the options wp_capabilities and wp_user_level
    4. Set the wp_user_level line to 0.
    5. Set the wp_capabilities line to
    a:1:{s:13:"administrator";s:1:"1";}

    Let us know if that works for you. Thanks!

  • Timothy
    • Chief Pigeon

    Hey there, I hope all is well.

    Just checking in to see how things are going here, its been a short while since we heard from you.

    If you still need further help then please feel free to reopen this thread or create a new one.

    Take care and have a great day! :slight_smile:

  • iBusinessLogic
    • Design Lord, Child of Thor

    Greetings,

    Mysteriously I have a very similar problem on http://kreweofshamrock.com . The membership plugin was operating fine on a development server and then after transferring the entire site to the main domain and going live all was well. From the front end everything is working as advertised but for the admin I have lost the following:

    Updates Menu

    Widgets Menu

    Users Menu

    Add/upload themes menu

    Add/Upload Plugins Menu

    I do get this nag message when logged in:

    You are logged in as a Membership Admin user, you will therefore see all protected content on this site.

    I asked for help from HostGator on this issue after not finding anything in search of numerous sources. They spent at least 45 minutes looking at the tables and the installation and I went through several levels of support (Host Gator is great by the way), and they have identified the problem as being with this membership plugin. I have tried the fixes above and have tried setting a membership level to Administrator with positive rules set for everything but no luck.

    The funny thing is that the missing menus in Admin are also missing in the positive rules settings in the membership plugin.

    The site was functioning correctly yesterday morning without anything being changed (other than the proposed fixes) since then…

    This is not a development site now, and it has been advertised to the membership for full use. Please come back with some sort of solution to this issue as soon as possible. Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.