No button on registration page

Our registration page (www.xpansion.co/subscribe) is missing the button on the screen that is displayed after you've selected a membership and entered your username, password, etc.

The page says: "Sign up for Xpansion.co monthly subscription
Please check the details of your subscription below and click on the relevant button to complete the subscription." This is followed by a table with the following: "Xpansion.co monthly subscription R199.00 per month" and then there's a blank cell where I assume the button to proceed should be.

I have set up a payment gateway (2checkout) and am not logged in when trying to sign up, so I have no idea why no button is displayed.

I'd really appreciate some help getting this resolved. Thanks!

  • Tom Eagles
    • Syntax Hero

    @Nathalie

    Thanks for getting back to me so fast, membership is one of those plugins where its quite easy to miss a step.

    Could you double check your settings using the manual here and also our cool video guides here.

    If you are still having the issue afterwards then i will bring in the developer.

    One final thought, you are not logged in when testing this are you? please try in a totally different browser.

    Cheers

  • Nathalie
    • WPMU DEV Initiate

    @Tom

    I've double-checked the manual and everything seems to be right. I've seen a couple of other posts with the same issue and the only one I've seen that was resolved was fixed by upgrading the plugin, but I recently downloaded and am on Version 3.4.4.1 so that can't be my problem.

    I've tried some of the suggestions from the other posts...

    I tried specifying the width of the purchasetable class in the subscriptionform stylesheet and even reducing the widths of the first two columns (although the column widths didn't change on the front end).

    I've double-checked and the 2checkout gateway is definitely active.

    I tried changing the theme to twentytwelve, but the button still isn't displayed.

    With debug on, I get these errors on the dashboard:

    Notice: get_theme_data is deprecated since version 3.4! Use wp_get_theme() instead. in /mounted-storage/home66c/sub007/sc39832-HKLW/xpansion.co/wp-includes/functions.php on line 2871
    
    Notice: Constant WP_POST_REVISIONS already defined in /mounted-storage/home66c/sub007/sc39832-HKLW/xpansion.co/wp-config.php on line 96

    I'm just not sure if these issues have anything to do with the issue though.

  • Nathalie
    • WPMU DEV Initiate

    @Tom

    Sorry, forgot to include errors shown when debug is on and all other plugins are deactivated:

    Warning: include(/mounted-storage/home66c/sub007/sc39832-HKLW/xpansion.co/wp-content/advanced-cache.php) [function.include]: failed to open stream: No such file or directory in /mounted-storage/home66c/sub007/sc39832-HKLW/xpansion.co/wp-settings.php on line 58
    
    Warning: include() [function.include]: Failed opening '/mounted-storage/home66c/sub007/sc39832-HKLW/xpansion.co/wp-content/advanced-cache.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home66c/sub007/sc39832-HKLW/xpansion.co/wp-settings.php on line 58
    
    Notice: get_theme_data is deprecated since version 3.4! Use wp_get_theme() instead. in /mounted-storage/home66c/sub007/sc39832-HKLW/xpansion.co/wp-includes/functions.php on line 2871
    
    Notice: Constant WP_POST_REVISIONS already defined in /mounted-storage/home66c/sub007/sc39832-HKLW/xpansion.co/wp-config.php on line 96

    I'm no expert, but I don't think any of these is related?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.