No Confirmation Emails Being Sent (Subdomains)

I have a Wordpress Multisite installation with the Membership Plugin activated. Everything on the site is working great but I have one major problem. I've looked all over for a solution, so hopefully someone here can help.

The problem is that subdomains don't send a confirmation email when a new user is added or if the admin email address has changed. This is not a problem at the network level.

I've allowed owners/administrators of subdomains to add new users to their subdomain even if they're not registered at the network level. Unfortunately, only a super admin can add users because a confirmation email is never sent.

Please help.

Thanks!

  • quantumpolitics
    • Flash Drive

    I just wanted to say that I was able to solve this with the WP-Mail-SMTP plugin. It now works in conjunction with the New Blog Template plugin and is auto-activated with other plugins from the blog.

    Hopefully, there will be an easier way to do this in the future.

  • aecnu
    • WP Unicorn

    Greetings quantumpolitics,

    Thank you for being a WPMU Dev member!

    What this shows to me is that it is almost sure to be a hosting related probably due to mod_sec or email security not allowing the normal php send to take place from the sub domains.

    There are also numerous other server side security features that can foul this up. on the other hand it keeps spammers, scammers, and other criminals from relaying out off the server.

    In any event, happy to hear that you got this sorted out!

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.