No Facebook Comment box on web site pages and/or posts

Doesn't show 'facebook comment box' on my web pages and posts - so that I can post comments.

  • Tyler Postle

    Hey Manika,

    Hope you had a great Christmas and/or Holidays :slight_smile:

    I checked out your site and it looks like the comment box is showing without any issues. I've attached a screenshot to illustrate.

    If you only want the Facebook comment box to show and not the WordPress one then you can check the "override WordPress Discussion Settings" option, then it will display only Facebook comment box and no WP comment option :slight_smile:

    Hope this helps Manika! Let us know if you have any further questions.

    All the best,
    Tyler

  • Manika

    Hi Tyler,

    Thanks for replying. Hope you had a good Christmas too!

    I deactivated 'bbpress post topics' plugin and UF comment box is showing without any issues. I was quite happy and had a big slice of pie (Christmas left over! Also kinda snubbed my husband because I was able to solve it by myself).

    But my happiness was short lived, the Wordpress comment box starting generating error message when used (I am enclosing the error printscreen).
    "Warning: Missing argument 2 for decode_utf_8() in /home/monash5/public_html/onlychildonhub/wp-content/plugins/wpmu-dev-facebook/wpmu-dev-facebook.php on line 220 etc.....".

    I tried to troubleshoot it to no avail. In the end (had to take my husband's help grudgingly):
    1. I deactivated all the plugins except UF plugin.
    2. Changed my theme from Suffusion to WordPress default theme - TwentyFourteen.
    3. The error still persists :slight_frown:.
    4. My site used to a very old site, created during WordPress 2.x version times, and once was a WP MU site, and was recently changed (NOT upgraded) to a regular latest WP site.

    I though the UTF() problem might be coming from an old post. So created a new post (called testpostone), but get the same error message.

    Basically, I ran out of ideas to further troubleshoot the issue. Could you please help (while I drown my helplessness in another slice of apple pie)?

    Thanks,
    Manika

  • Michelle Shull

    Hiya, Manika!

    I grabbed a piece of pie for inspiration. The ladies have got this. :slight_smile:

    Let's look elsewhere, I believe this UTF is a clue. Can you log into your server control panel and then into your database and see if it's set to Latin or UTF-8? If you installed this years ago, there's a chance you've got a less-than-modern setting in your database that didn't reveal itself until right now. I took a screenshot of my DB so you can know where to look.

    If this is the issue, there's a fix. http://codex.wordpress.org/Converting_Database_Character_Sets

    And a slightly simpler fix: http://alexking.org/blog/2008/03/06/mysql-latin1-utf8-conversion

    Hope this helps!

  • Manika

    HI Michelle,

    Sorry, I was in a hurry this morning (time difference between Australia and US!) and didn't get time to reply in detail. Thanks for the screenshots you provided.

    I tried a lot of the things that you had recommended, with no luck...After a lot of frustration and code reading, I decided to create a completely fresh installation of WP to eliminate possibilities. And that's when I found that the UF plugin gives this error even on a new installation with default theme and no other plugins running.

    My site is waiting for you guys to look at (all plugins deactivated, default theme running- not good for traffic). If you guys at WPmuDev are unable to sort it out, please let me know so that I can have my husband look at it. He says that the "Farmer" dude at your place might know what the issue is, don't know what he means.

    Have you guys tried installing this plugin on your end and trying?

    Its school holidays here (peak of summer here- southern hemisphere), so I'll check my mail occasionally.

    cheers!
    Manika

  • Tyler Postle

    Hey Manika,

    Hope you're doing well today!

    I've just tested out my installation and I'm not getting that same error. Often the cannot send headers warning happens when there is white space before the opening <?php tag in a file or at the end of the file, but that doesn't look to be the case here as the error seems to be happening in the middle of it for you.

    The first warning you get there I also see in my debug log too. This one:

    PHP Warning:  Missing argument 2 for decode_utf_8() in /home/suppmedi/public_html/wp-content/plugins/wpmu-dev-facebook/wpmu-dev-facebook.php on line 220

    I'm also getting these ones:

    [29-Dec-2014 21:21:36 UTC] PHP Warning:  Illegal string offset 'button_appearance' in /home/suppmedi/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_admin_form_renderer.php on line 424
    [29-Dec-2014 21:21:36 UTC] PHP Notice:  Uninitialized string offset: 0 in /home/suppmedi/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_admin_form_renderer.php on line 424
    [29-Dec-2014 21:21:36 UTC] PHP Warning:  Illegal string offset 'button_appearance' in /home/suppmedi/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_admin_form_renderer.php on line 429
    [29-Dec-2014 21:21:36 UTC] PHP Notice:  Uninitialized string offset: 0 in /home/suppmedi/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_admin_form_renderer.php on line 429
    [29-Dec-2014 21:21:36 UTC] PHP Warning:  Illegal string offset 'button_appearance' in /home/suppmedi/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_admin_form_renderer.php on line 434
    [29-Dec-2014 21:21:36 UTC] PHP Notice:  Uninitialized string offset: 0 in /home/suppmedi/public_html/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_admin_form_renderer.php on line 434

    just posting those for Umesh to see as he is one of our awesome developers :slight_smile:

    Do you have wp_debug set to true in your wp-config.php file?

    If you set it to false like this:

    define('WP_DEBUG', false);

    Then it should hide those php warnings :slight_smile:

    Let us know if you need any further assistance!

    All the best,
    Tyler

  • Umesh Kumar

    Hi @Manika,

    Can you enable the support access?

    Also, just send me the following details:

    You can go to
    https://premium.wpmudev.org/contact/
    On the contact form, select "I have a different question"

    Can you please send in:
    - In the subject field add "Attn: Umesh Kumar"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    this ensures it comes through and gets assigned to me.

    Cheers

  • Umesh Kumar

    Hi @Manika,

    PHP display_errors was turned on, on your site which was causing the white screen.
    I've modified your wp-config.php to turn it off, so the current version will work fine for your site.

    Also I've fixed those warnings in the plugin, it'll be available shortly in your updates.

    Please update Facebook API settings in the configuration, they were removed as I've reinstalled the plugin on your site.

    Cheers

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.