No Favicon - Ultimate Branding

My ultimate branding favicon worked when my site was in development; now that it has been moved, however, the favicon will not display in the browser.

  • Brian
    • New Recruit

    Vaughan, thanks for your suggestions. Yes, I've tried reuploading it. Size is 16px x 16px (file size is ~1KB). I've tried both .gif and .png. I've tried clearing/resetting the image, manual uploads, clearing caches, and all advice I've found in the forum thus far. It didn't work on the dev server until I manually uploaded it. Now, on the live server, it works - I can see the favicon in the admin panel - but it doesn't actually show on any browsers (though it did on the dev server).

    Any other suggestions would be appreciated! Thanks!

  • be
    • WP Core Meltdown

    @Brian

    Hi Brian, I had the same quirk,
    Ie: my favicon was there then for a day I had been working on the site, it no longer showed.
    I cleared cache, refreshed and still no favicon.
    Logged in the next day and it was there so unsure if it was the logout/in because I did nothing else to change the behaviour..
    It has remained as it should since that first time.
    I also note Ultimate Branding does not require a .ico to function

  • Kenton
    • WPMU DEV Initiate

    Hi Brian,

    I myself had the same issue and it works when I use .jpg
    (.png, .ico, .tif, .tiff, and .gif would not work.)
    I know this is last resort but:
    You could try uninstalling/reinstalling the plugin.
    Making sure to delete the actual folder from within plugins.

    Cheers,
    Kenton

  • aecnu
    • WP Unicorn

    Greetings Brian :slight_smile:

    If you have indeed uploaded the .ico to the root of the installation and it does not show up in a browser in a day or so - you may want to go ahead and check the theme as well.

    The reason why a day or so is because I have found that when changing the favicon (if the theme does not specify it as mentioned below) - that it takes a couple of days to work its way through.

    Some themes specify the favicon location and in this event I use .png files.

    You did not mention what theme you were using?

    In any event - happy hunting.

    Joe :slight_smile:

  • sremington
    • Site Builder, Child of Zeus

    Yeah if it's in your root then make sure your header.php file calls it in. Should be near the top and looks similar to this:

    <link rel="icon" href="http://www.mydomain.com/favicon.ico" type="image/x-icon" />
    <link rel="shortcut icon" href="http://www.mydomain.com/favicon.ico" type="image/x-icon" />

    If that isn't there just paste it in and obviously replace "mydomain" with your domain.

  • Brian
    • New Recruit

    Well, here's the thing: it worked before I moved it to a new server, and it doesn't work now. I know I could call the favicon in the header, etc., but I purchased UB so I would prefer it simply work through that interface. Under the "images" tab, the correct image does display. It just never shows as a favicon.

    If there are no other ideas, I can try a re-install or simpy call it with the theme (it's a custom theme).

    Thanks for all your input

  • Brian
    • New Recruit

    be, I think your solution worked, if it is to be considered a solution. :slight_smile: Today, the favicon displays correctly. I'm not sure what happened. I'm marking this as resolved.

    Thanks to everyone for your input!

  • be
    • WP Core Meltdown

    @Brian.

    Glad it did, I know there appears to be some latency issues with some of the items, as long as you can see the actual icon in the Ultimate branding plugin, it can see the path.
    Latency is the only real explanation..

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.