No option for portal template in WHMCS

I only have the option to select "five" or "six" in my theme selection dropdown on WHMCS. How do I get the portal theme?

  • Sajid

    Hi @Devon

    Hope you are doing good today :slight_smile:

    Its because WHMCS no longer support old themes as seen in their disclaimer on release note.
    http://docs.whmcs.com/Version_6.0_Release_Notes regarding this.

    With the release of WHMCS 6.0, we are also deprecating our two oldest client area template themes - classic and portal. As of this release these client area template themes will no longer ship with WHMCS and will receive no further updates. They will continue to remain in the 5.3.x releases until such time as 5.3 reaches End of Life.

    We strongly recommend that all new custom themes and templates are built based off the latest current client area template theme six in order to take full advantage of the latest improvements and new functionality.

    Since its not maintained and updated by WHMCS that's why it not included in the plugin. However if you select automatic and select the theme in WHMCS this will use the default theme you selected there. If its still not loading then let me know and I will flag developer for their invaluable feedback on this matter.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

    • Jerone

      Please help... I think I had enough lol... It was working at first and now it's not... I'm not sure what the heck I did, but I'd like to piggy back off of this issue... Let me know if I need to start a new thread but here is what I'm experiencing...

      I go to my settings and configure the settings to show the URL of the whmcs install. I'm using sub directory... So in the Remote Host URL I have the following: http://mywebsite.com/mywhmcsinstall

      I choose the page from the drop down menu that I has the [wp_content] shortcode.

      The template I chose was Six because that is what I have selected in my actual WHMCS settings

      this did nothing for me...
      I changed the template to Portal...
      this nd nothing for me...

      I changed it to Auto Detect and still... nothing

      I verified that both my Remote Host URL and my WHMCS System URL are an exact match...

      Still nothing.... When I visit the page with the wp_content shortcode it simply redirects back to my home page... I notice in the directory that it shows myhomepage.com/?syspl=six or /?syspl=portal
      but shows no errors and simply redirects to my homepage...

      Again, this was working before. I can't recall what I did last, so I'm not certain if its a plugin. I deactivated a lot of plugins that I added after I know it was working and no luck... I'm lost at this point... I've been trying to get this site launched for months and keep running into challenges... Your support team has been very helpful... I'm hoping and thinking that this is the last hurdle... lol Please let me know... I may have to get you access to my actual site. Let me know if it's necessary, unless you have seen this before...

      The only thing I can possibly think of is that my cloud server has two IPs. One is a main and the other is a secondary. I had my hosting company swap them around in order to get the wpmudev domain mapping plugin to work without me having to manually go in and change the dns settings to the secondary IP instead of the main IP... not even sure if that worked because I haven't created any sites lately... but that is the only significant thing I can think of... Due to the time in between that I kind of tabled this issue, I can't recall if this issue existed prior to me making that significant change.. but again it was working fine at one point...

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.