"no preference" not working as it should

Hi there,
I have a service with 2 service providers, we use the "no preference" option.
Service provider 1 has 3 time slots: 10:00, 10:30 and 11:00
Service provider 2 has time slot 10:00
Service provider 1 doesn't work on Nov 11 (screenshot 1), Service provider 2 does (screenshot 2)

Yet when no provider is selected (no preference) the time slots from service provider 1 can be selected (screenshot 3)

This is not good at all and already caused a bit of trouble :slight_frown:. Can anyone help?

  • Bojan Radonic
    • Head of Support

    Hey again @ulir,

    Thanks for the access, I understand what you mean now.

    No Preference reflects working hours that are being set for "No Specific Provider" in Appointments -> Settings -> Working Hours, see screenshot.

    No Preference doesn't check for provider availability in that specific service but rather just uses working ours set for No Specific Provider. The reason for this is because in case there are mutliple providers to check for multiple days in the calendar this would result in very long queries affecting the speed of your site and possibly resulting in execution time errors.

    What you could do is use the following in your calendar shortcode:

    require_provider="1"

    This needs to be added in [app_monthly_schedule] so the total would look like this:

    [app_monthly_schedule require_provider="1" ]

    This will stop calendar from rendering until provider is selected. What you could also do is use translation files to change "No Preference" to "Plese Select Provider" or something similar. Could this work for you?

    Hope this helps :slight_smile:

    Best regards,
    Bojan

  • ulir
    • Site Builder, Child of Zeus

    Hi Bojan,

    thank you for the swift response!
    I'll use the "require_provider" option for now, although it is not exactly what we want ... Our experience is, that usually the first provider is selected if the customer has to do the selection.

    To be honest, I don't really understand the sentence

    No Preference doesn't check for provider availability in that specific service but rather just uses working ours set for No Specific Provider.
    because for service id 14 (and other servicces) it seems to be working just fine? The difference is, that for service id 14 the providers are available on tuesday and thursday while for service id 51 both have their time slots on the same day.

  • Bojan Radonic
    • Head of Support

    Hey again @ulir,

    It means that the open slots are not checking for specific provider working hours, it just uses "No Specific Provider" hours, this means the calendar shows the hours set in No Specific Provider and not the hours you set for your providers if that makes sense.

    Glad the above can work for you :slight_smile:

    Cheers,
    Bojan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.