No Refresh + Content Not Revealed

Hi there,

Finally got the plugin to display properly in my previous issue, thanks again for the help there.

Now unfortunately the page doesn't refresh or reveal the content when shared. Here's a link to a test page, I've had to launch the competition without the plugin for now until I can get it to work.

http://drummersdatabase.com/comp/test-3/

Please help me ha!

Dave

  • Kimberly
    • Champion of Loops

    Can you check it out with all the other plugins disabled? I see you have a social share pack and I'm wondering if there is a conflict somewhere with the API call for the social sites.

    Sometimes if you are using an API in more than one spot it can confuse a plugin.

  • davejmason
    • Site Builder, Child of Zeus

    Hi Kimberly, sorry, I've disabled everything apart from PWAL and still getting the same result. The content will load if I refresh the page manually but I need this to happen automatically.

    Note: This happens on all sites across the network. Not just the one I'm trying to use it on.

  • davejmason
    • Site Builder, Child of Zeus

    Just looking into this again now. I have another competition comping up soon and I'd really like to get it fixed in time.

    To update, when I disable ALL plugins, it works. Albeit with a separate but annoying bug where when the user clicks 'like' it displays a dropdown that isn't visible/cannot be accessed. (screenshot below)

    So I guess this means it's a plugin issue. I also have to assume that because it's happening on all of my subsites that it is a network activated plugin, correct?

    I'll continue to test and see what I can come up with.

  • davejmason
    • Site Builder, Child of Zeus

    Ok so my progress so far:

    I'll call my main site DD and my test site TS to make things easier. Both are multisite installs WP 3.4.2 and latest versions of everything else used.

    1) Disabled all plugins on DD - refreshing now works on all themes. Tested with multiple posts.

    2) Re-enabled BuddyPress on DD - Boom, no longer refreshing.

    3) Thinking I've caught the culprit, I decide set up on TS (it's bare)

    4) I install PWAL on TS and test on twentyeleven - it works fine

    5) I install Buddypress on TS and try multiple times. It still works. (Strange, Buddypress breaks it on DD.)

    6) I switch TS theme to buddypress default. Still works

    7) I go back to DD and try on twentyeleven and buddypress default. Still not working.

    8) Not sure what to do now so I revert DD back to twentyeleven and switch off buddypress. It now works again.

    9) Now wondering if it's just Buddypress or any plugin I begin network activating plugins on DD, beginning with WPMUdev dashboard. Still working.

    10) All in one SEO - fine.
    Buddypress Album - fine.

    11) I now activate all other original plugins except for Buddypress - Still working.

    12) To confirm, I reactivate Buddypress..... broken again.

    So obviously Buddypress isn't getting on with PWAL on my website, even when using the twentyeleven theme. Where as when I use buddypress and PWAL on my test site, it's fine.

    If it's of any relevance, when I activated buddypress on DD, I got this error message:

    "The plugin generated 1 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin."

    Any ideas where to go from here? I have about 2 weeks to get this sorted maximum. I can provide you with ftp/admin logins etc if you need.

    Thanks for looking into this!

    D

  • Hakan
    • The Incredible Smush

    Hi,

    I see one issue on your theme:

    <script type="text/javascript" charset="utf-8">
    			/* <![CDATA[ */
    			var ajaxurl = 'http://drummersdatabase.com/wp-admin/admin-ajax.php';
    
    						/* ]]> */
    		</script>
    <script type="text/javascript">var ajaxurl = 'http://drummersdatabase.com/wp-admin/admin-ajax.php';</script>

    You have redundant ajaxurl definitions on your website. This may or may not cause the issue you meet. Remove the code from your theme that is calling the second ajaxurl and try again.

    If this does not help please send me your login credentials using our contact form:
    https://premium.wpmudev.org/contact/

    Cheers,
    Hakan

  • Hakan
    • The Incredible Smush

    Hi Dave,

    I made several hours of tests on your website and I believe this is because of a unique combination of your server configuration and settings (Cloudflare + transfer encoding:chunk + domain mapping + json incompability).

    Can I also ask your FTP credentials in order to find a fix for it? Because I cannot replicate this issue on my own server.

    Cheers,
    Hakan

  • Patrick
    • Support Monkey

    Hiya @davejmason

    Just checking if this issue has been resolved, either by yourself or with the excellent assistance provided by @Hakan?

    If so, no need to reply, that’s great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.