no step 2 in registration process

Hi there

Please help me out. I have no idea what I'm doing wrong settings wise, or if its my installation of what... but i'm not ever seeying the "step2" of the registration process. Users simply register an account... but does not get offered a subscription choice or payment options. :slight_frown:

I have set up all the sections as per the instructions; levels, plans & gateways. Everything seems fine. Except the front. I'm using wpmu, buddypress and membership pro.

Thanks
mike

  • Kimberly
    • Champion of Loops

    Mike,

    Hi and welcome to WPMU fourms :slight_smile:

    How are your users signing up?

    Do you have a screen like this inplace?

    You should be using the membership page you allocated to the registration form or a page with the [subscriptionform] shortcode

    Also you need to set your stranger settings to visitor and, if you don't want to offer a Free level subscription that you set your General Options>User Subscription to None. If you have this set to anything else then you will be signing people up to the free account by default and they will have to Upgrade to a paid subscription. :slight_smile:

    If this doesn't work then I'll ask you to please re-open the ticket and post a screenshot of your settings so we can figure out what the who is going on :slight_smile:

    Best and Thanks for being a WPMU member!

    Kimberly

    If this thread is not resolved because the suggested action did not work or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

  • KevinDLyons
    • Flash Drive

    Mike,

    What payment gateway are you using? With the Authorize.net gateway there seems to be a problem with loosing the user information when the site switches from http to https for the payment page. I believe this is an issue with the session variable.

    I have seen this as an issue with other platforms dealing with the COOKIEPATH setting. There is a small mention of it on Wordpress.org here: http://bit.ly/Am3LXW.

    As a short work-around, if you are using a payment gateway that flips the site from http to https during the subscription process, you can manually set the link that the user clicks to a https path, i.e., "https://yourdomain.com/pagewithsubformonit"

    It would be great if Barry or another developer could work this through. I'd gladly colab with them on it.

    Thanks,
    Kevin

  • fullcream
    • New Recruit

    Hi Kimberly

    Thanks for the reply. I've tried everything now, but I'm still not seeing anything close to the above page (step 2), and instead only see the "register" form above. The "register" page has the shortcode [subscriptionform] on the page as displayed by screenshot.

    Also, settings shots attached too.

  • fullcream
    • New Recruit

    Hi Kevin

    With the current settings as as, a use gets created fine in wordpress, but does not get assigned a subscription or membership level. Then again, the user never gets a choice either way.
    After logging in as "jack", the register page redirects to the "no access" setting page, so no, still no step 2 anywhere.

  • KevinDLyons
    • Flash Drive

    Do you have the register page protected somehow? Or maybe excluded in your stranger settings? There are a couple of settings surrounding how to deal with a user/non-member on the site. It looks like you have your stranger set up though...

    Kimberly, thoughts?

    Thanks,
    Kevin

  • fullcream
    • New Recruit

    Nope, register page is fine, with no restrictions (stranger saw it after all).
    Yeah, I think the settings generally look like they should, and everything makes sense all around (the membership workflow is pretty logical)... but still, no luck on ever seeing the illusive "step 2". :slight_frown:(((((((((

  • ThePath
    • The Bug Hunter

    Hello all,

    Thought Id chuck in my two cents here. Ive recently installed Membership and came across a blank stage 2 screen also, so run through these and see if it helps:

    1. Make sure you "Enable incomplete signup accounts " in the options screen (see screenshot). This will allow you to revisit the registration page with test users you have created (but only got to stage 1 with).

    2. Make sure membership protection is enabled in the first "Membership" menu. You have already mentioned that you have enabled and made the subscription plans public so thats fine.

    3. Make sure you have a payment gateway setup and activated. So make sure all the settings within the payment gateway are setup.

    4. Make sure you have created and set your registration page (see screenshot bottom) in the options menu. Looks like you have done this from your screenshots though.

    I have to say your screenshots all seem to be correctly setup.

    The one thing I would say is when I installed Membership I can no longer access the usual registration page (although I have it on a single with no BP). See the second screenshot. But perhaps the integration with BP is different.

    @Kevin yes you are right about the problem being sessions. Basically your not allowed to pass the session variables for security reasons. Its not specifically and Authorize.net issue. It happens if you are on a shared SSL too. So if you jump from http://yourdomain.com to https://secure-secure.com/yourdomain.

    Mmm well I dont think Ive been to much help really, but just double check everything and hopefully you spot something.

  • fullcream
    • New Recruit

    Hey guys.

    I'm still very stuck. I tried the setting suggestions from @ThePath, but nothing changed.

    Kimberley, I kinda figured that it was the buddypress registration I'm seeing, but since I'm using the shortcode on the right page, I thought it would just 'take over' from buddypress. so not sure whats up there. I tried your link too, even resorting to completely removing membership and trying from the top. :slight_frown:

  • fullcream
    • New Recruit

    Wow. I found the issue. Can't believe it so simple and stupid at the same time.

    @KimberlyL got me thinking about the buddypress conflict causing the issue... so I recreated the "register" page as "signup", with the same shortcode, and set Membership to use the signup page instead. So it turns out that the buddypress setting for the register page, and the Membership register page should be different.

    Go figure - turns out to be a simple setting after all. doh!
    Thanks for all the help though.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.