No Valid Header

I tried to install the Upgrades plugin version 1.5 today, but I received a message saying there is no valid header. Will this be fixed soon?