No valid shipping options found. Please check your address carefully.

I tried to do a trial order for my website after receiving no orders on our first day of launch.

I put my information in and when I tried to submit the shipping information it said "No valid shipping options found. Please check your address carefully."

There was no issue with my information. Please advise. This plugin seemed very easy to setup compared to WP E-Commerce or WooCommerce but so far I have had nothing but problems.

I would like some individual attention to help get this shop running properly. Thank you in advance.

  • nolan_ether
    • Flash Drive

    Do the other settings matter as well? Do I need a max weight? I changed my box sizes as well to custom sizes (2 of which have the same weight/different products) (which pertains to another open ticket I have floating around somewhere that a lead developer is supposed to be looking in to).

  • aecnu
    • WP Unicorn

    Greetings nolan_ether,

    Sorry to see that you are having issues with your store opening and yes it is of the utmost importance to get you going of course.

    One of the biggest problems that members face is that they do not completely configure a plugin and expect it to work and though I am not sure, by what you mentioned above this is indeed the case:
    Do the other settings matter as well? Do I need a max weight?

    All settings matter sir.

    **********************

    which pertains to another open ticket I have floating around somewhere that a lead developer is supposed to be looking in to

    This is the ticket you are referring to which by the content of the ticket we are in may negate the other ticket:
    https://premium.wpmudev.org/forums/topic/fedex-shipping-integration

    **********************

    I have indeed visited your site which looks very nice and Kudos on that aspect. I then went and tried to place an order and I got the same reaction you did but also it appears that you are not connecting up with the USPS system.

    Do you indeed have a valid USPS account? Is the USPS user name in place?

    I will certainly keep digging in and surrender is not an option.

    Please advise.

    Cheers, Joe

  • nolan_ether
    • Flash Drive

    I do have a valid USPS account w/ API and the correct username is in the box.

    With regard to the settings, not sure what to do here. For max weight, why would I want to limit the order? If someone wants 50lbs then that's 25 boxes of cookies. Why would I want to make that impossible?

    Along the same lines, yes the other ticket I'm referring to is linked above where we talk about using custom boxes and having a few different boxes be for products of the same weight but for different products.

  • aecnu
    • WP Unicorn

    Greetings nolan_ether,

    Thank you for the additional input and perspective.

    You should check that the user name does not include a space at the front or the end of it which is common when a copy and paste is done when using Windows.

    You should call USPS and get what there maximum limit is that they indeed allow to be shipped per one single package.

    Please advise if we have had any resolution here.

    Cheers, Joe

  • nolan_ether
    • Flash Drive

    I think I've got it working, but an order hasn't been actually placed. It's not stopping me before calculating shipping now though.

    With regard to maximum limits, if the USPS has a standard limit for how much can be shipped per a single package, why is that not standardized in your system? If that's not a variable that changes then why even have it as a field?

  • nolan_ether
    • Flash Drive

    By the way, it wasn't an issue w/ username or anything, it was that I hadn't called to get it switched to their production servers yet. If this is a standard part of the process, why is it not written out in the documentation? I only found out about this by looking at other issues people were having in this forum.

  • aecnu
    • WP Unicorn

    Greetings nolan_ether,

    Thank you for your great questions and for letting us know that you managed to get the issue resolved.

    By the way, it wasn't an issue w/ username or anything, it was that I hadn't called to get it switched to their production servers yet. If this is a standard part of the process, why is it not written out in the documentation?

    Well sir |I do not know how much clearer it can be You must test and then Activate your credentials with USPS before going live.

    Screen shot below.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.