Non-existent changeset UUID.

I get this error when going to the customizer of some of my websites:

“Non-existent changeset UUID.”

This error on the customizer only shows up on subdomains that have been mapped. It does not effect the front of the site or any other part of the site. I just cannot use the customizer for any of my mapped subdomains.

How do I go about solving this issue?

  • Kasia Swiderska
    • Support nomad

    Hello Michael,

    Thanks for letting us know that it started to working. I also tested it on my multisite to see if I could replicate that issue, but I could not. Customizer opens fine on my mapped subsite.

    If this happen again please feel free to re-open this thread and we will investigate it.

    kind regards,

    Kasia

  • Michael
    • Site Builder, Child of Zeus

    So the issue came back. But it acts weird. The error will show up until I make a change in the customizer. Once I make a change the error goes away and I am able to use the customizer. Again, only for subsites with a mapped domain.

    Is there a way for the error to never show up?

  • Nithin
    • Support Wizard

    Hi Michael,

    Hope you are doing good today. :slight_smile:

    So the issue came back. But it acts weird. The error will show up until I make a change in the customizer. Once I make a change the error goes away and I am able to use the customizer. Again, only for subsites with a mapped domain.

    This is odd, could you please clear you browser cache, and check whether you are able to replicate the same issue. If you are still having issue, just to be sure whether any other plugin is causing this issue, could please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.

    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If the above instructions doesn’t help much, and if you still have the same issue, please enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Michael,

    Hope you are doing good today. :slight_smile:

    Thank you for enabling support access, this is really odd, and I could notice the issue with all the 3 mapped domains. Is it possible that we could switch the themes for these 3 subsites, and check whether the customizer works fine with a default WordPress theme? What I could notice, is that all the 3 substies uses the same theme, and I would like to make sure whether there isn’t any conflict with the child theme/parent theme that you are using.

    Since it’s a live website, I didn’t make any such theme switch. Please do let us know whether we could switch, and see how that goes. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Rupok
    • Support Ninja

    Hi Michael,

    I just tried to login with Support Access to investigate the issue, but it's showing me the following error:

    Can you please talk to your host regarding this? Please let us know when we can access your site with Support Access and investigate the issue to find a solution.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!

    Rupok

  • Kasia Swiderska
    • Support nomad

    Hello Michael and Teignview,

    I found that this error was reported as bug, then they investigated and it was WP Super Cache https://core.trac.wordpress.org/ticket/39128

    https://github.com/Automattic/wp-super-cache/pull/161

    I see more people reporting this issue on sites where there is no Domain Mapping https://wordpress.org/support/topic/non-existent-changeset-uuid-in-theme-modify-screen/

    Does any of you have Super Cache?

    Michael – I’m not able to check that on your site because there still 403 error. I can try direct access if you could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    – Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska

    – Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.

    – Link back to this thread

    – Include WordPress network admin access details (login address, username & password)

    – Include FTP log-in details (hostname, username & password)

    – Include any relevant URLs for your site

    IMPORTANT: Please make sure you select “I have a different question” for your topic, so it doesn’t go back to the forums – this and the subject line ensure that it gets assigned to me.

    Please confirm here when you will send those credentials

    kind regards,

    Kasia

  • Nithin
    • Support Wizard

    Hi Teignview,

    Hope you are doing good today. :slight_smile:

    No Super Cache and domains not mapped work fine so looking like a domain mapping issue as it is only mapped domains that show the error

    Thank you for letting us know that you don’t have the plugin installed. If you had WP Super cache installed before, please check your directory for any files/folders related to the cache plugin, for eg:wp-content/advanced-cache.php. If you find any files related to the plugin, please do delete them, and see whether that makes any difference. Please do make sure to take a backup, before making such changes.

    If you meant that you haven’t installed that plugin at all, then it could be related to something else. I could see that you already have a open thread regarding this, would recommend that you follow your thread so that one of the support staff could give a closer look at your install:

    https://premium.wpmudev.org/forums/topic/non-existent-changeset-uuid-1/

    Kind Regards,

    Nithin

  • Michael
    • Site Builder, Child of Zeus

    I got this error as well when trying to view any page besides my home page.

    “Unauthorized. You may remove the customize_messenger_channel param to preview as frontend.”

    Wordfence may have blocked your IP address. Can you supply it? I also sent an email with everything but FTP login details

  • Kasia Swiderska
    • Support nomad

    Hello Michael,

    Thank you for sending me credentials – checked again your site and I was finally able to replicate issue on my site they same way you see it on your site. Strange that this issue shows and goes, but I can see that my colleague in second thread was also able to replicate and bug is already reported to developer.

    I’m adding your thread to that bug report so you will be updated when there will be fix for it.

    kind regards,

    Kasia

  • Michael
    • Site Builder, Child of Zeus

    Id rather access the site through super admin so I can make changes with my single login. I do not want to login in on a per site basis and log out just to make changes to my entire network of sites. That defeats the purpose of having a multi site network.

  • Dorlita Blakely
    • WPMU DEV Initiate

    I just experienced this same issue after activating the Hummingbird plugin over the weekend. I just deactivated that same plugin and everything went back the way it is supposed to work. My sub sites themes and plugins were completely broken before I disabled it.

  • Rupok
    • Support Ninja

    Hi Dorlita Blakely,

    So sorry to hear the inconvenience you are having. Do you have Domain Mapping enabled and don’t face this issue with Domain Mapping when Hummingbird is disabled? If yes, then this is a new issue.

    In that case, can you please create a new thread with your issue so we can troubleshoot this on that thread? If we can regenerate the same, we will report to our developer right away.

    Having different threads for different issues helps both you and us to track down the steps already taken and facilitates the troubleshooting process. I hope you understand.

    Have a nice day. Cheers!

    Rupok

  • pmsteil
    • Site Builder, Child of Zeus

    Hello all,

    I am getting this same error when I visit the customizer and only on ONE of our sites that we can tell, have tested several others and they are fine.

    Non-existent changeset UUID.

    Warning: ksort() expects parameter 1 to be array, null given in /home/churchw9/public_html/wp-content/plugins/ubermenu/pro/fonts.php on line 59

    Warning: Invalid argument supplied for foreach() in /home/churchw9/public_html/wp-content/plugins/ubermenu/pro/fonts.php on line 62

    – Running on WP 4.8.1.

    – I had Hummingbird installed, but not activated and I deleted it.

    – I have the Breeze caching plugin installed. Deactivated it and no change.

    – I have WordFence, deactivated it and no change.

    – It does have a mapped domain via Domain Mapping (still on v4.4.2.1 because 4.4.2.5 has a conflict with the X Theme Cornerstone editor apparently).

    Any other ideas for me to try. Happy to grant support access if needed.

  • Kasia Swiderska
    • Support nomad

    Hello pmsteil,

    Issue with customizer and “Non-existent changeset UUID.” will be fixed in next release of the Domain Mapping. I checked status of the bug report and solution to this was implemented in current beta version of plugin so we should get soon a new update.

    kind regards,

    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.