Non Membership Shortcodes

[officials 2.1 release]

Membership is replacing shortcodes supplied by other plugins like this:

[raw]
[cudazi_iconlist]
[cudazi_iconlist_icon icon='risegraph32.png' heading='1st Class Extras' text='1st Class members premium content' link='#']
[/cudazi_iconlist]
[/raw]

with my No Access Message of: You need a First Class subscription to get this content. Subscribe here.

What gives? I know it has to do with my settings for that membership level, but I'm finding the whole process of Editing a Membership Level really confusing.

I have 2 paid levels: testdrive that goes a week and then becomes 1stClass. I want to protect content in general so that strangers, or people registered at free level do not see protected content.

1. what is the simplest configuration in Edit a Membership level that will do this, and not nothing more?

2. Can I leave my No Access Message blank and will that just completely hide protected content?

(one more - how do I do a search for something in just Membership Forum posts?)

  • DavidM
    • DEV MAN’s Mascot

    Hi BobWalsh,

    The shortcodes are usually displayed unrendered like that when you view the site as Admin, is that the case? If so, it's best to use another browser, log in as a user and taking a look at how it all appears with that.

    As for your first question, you'll need to simply setup your membership level, the setup a subscription where the free level is set to Finite with a 1-week duration, then the 1stClass level is set to whatever duration you want that set for.

    It sounds like your membership level is setup correctly and perhaps just needs to be checked out as a logged in member?

    For your second question, if you don't specify a No Access Message it shouldn't display anything, but your content should still be hidden.

    Have you tried that yet?

    Thanks,
    David

  • BobWalsh
    • WPMU DEV Initiate

    Short code is Not displaying unrendered - membership is hijacking the code and replacing it with the No Access message. (I included the shortcode in this post just to show you it)

    This is not a logged in issue - it's a configuring membership level issue.

    For a premium membership level, I want to use a shortcode that protects certain content, hide certain menu items unless the visitor is at that premium level. How do I do that?

  • DavidM
    • DEV MAN’s Mascot

    Hi BobWalsh,

    Really sorry I misunderstood your original post! I see what you mean now, that Membership is blocking those shortcodes.

    In Membership > Edit Options you'll see a "Shortcode visibility default" setting, you can set that to Yes or No. With it set to Yes, you'll always be able to see other shortcodes by default.

    Likely, this is why the content is being hidden, and giving the "No Access" message.

    And from there, you can restrict/show shortcode content using the Shortcode rule in your membership level. The Shortcode rule lets you tick any available shortcodes on your site so you can hide or make them available for particular levels.

    You wouldn't need to use a shortcode to restrict the display of menu items actually. You can use the Menu rule, ticking the items you want to restrict/show, as shown below.

  • Philip John
    • DEV MAN’s Apprentice

    Hiya,

    As we haven't heard back from you we're going to assume the problem was sorted out and mark this thread as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and, as always, for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks,
    Phil

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.