Not able to install the dasnboard plugin on salsaindia.in

Not able to install the dashboard plugin gives this error

Could not create directory. /home/content/77/12182477/html/indiasalsa/wp-content/plugins/wpmudev-updates/

  • Rupok

    Hi exist2014, hope you had a wonderful day.

    This seems to wrong permission issue on your server. Can you please make sure you have proper permission for your files and directories on your server as suggested in the official documentation, here? https://codex.wordpress.org/Changing_File_Permissions
    In brief:

    # All files should be owned by the actual user's account, not the user account used for the httpd process.
    # Group ownership is irrelevant, unless there's specific group requirements for the web-server process permissions checking. This is not usually the case.
    # All directories should be 755 or 750.
    # All files should be 644 or 640. Exception: wp-config.php should be 440 or 400 to prevent other users on the server from reading it.
    # No directories should ever be given 777, even upload directories. Since the php process is running as the owner of the files, it gets the owners permissions and can write to even a 755 directory.

    Have you already installed WPMU DEV Dashboard Version: 4.0.8 on your server and trying to update? Please confirm.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi exist2014,

    Hope you are doing good today.

    Now could I share my login credentials with you, so you can have look, since I cannot enable access?

    Please do make sure that you follow the instructions mentioned in the above thread. I'm not sure why you aren't able to enable access, to get this sorted easily, could you please send us your credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: http://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username(master, and subsite)
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password) (master, and subsite)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day.

    Kind Regards,
    Nithin

  • Nithin

    Hi exist2014,

    Hope you are doing good today.

    I checked your website, and tried to install a plugin, it seems like you don't have the correct permissions for your files, and folders as mentioned above. I'm afraid, I'll need your FTP access, in order to make these changes. You could access your Cpanel, and create a FTP access.

    If you aren't sure about making these changes yourself, please do ask your host to make the required changes to you files, and folders as mentioned above.

    I hope this helps. Please let us know if you still need any further assistance. Have a nice day.

    Kind Regards,
    Nithin

  • Nithin

    Hi exist2014,

    Hope you are doing good today.

    This is really odd, I checked your dashboard, and now the plugins aren't visible. Going through your FTP, the plugins are intact, but it's not being picked in the dashboard. The default permissions for folders are 755, and 644 respectively. But your folders has permission set as 705. I tried to change these, but the plugins are still not picking in the dashboard.

    Also, the wp-config.php in your root folder is missing? Could you please point the location, where you have moved it? I could see a wp-config.php outside your root directory, but there is already another WP installation in that directory. Is that the one?

    I was able to notice, deprecated files in your /salsa root directory, these files aren't part of the default WordPress installation. Please advise, whether I missing something here?

    It seems like changing the permissions doesn't tend to work, your PHP settings might be overriding this, would recommend you to keep in touch with your host, and ask to make the default folder permission to 755, and 644 for files.

    I hope this helps. Have a nice weekend.

    Kind Regards,
    Nithin

  • exist2014

    Hey Nitin,

    I tried to contact GoDaddy with the above issue. Their stand is if you can log into the dashboard then you WordPress is fine, rest is all content related.

    I need a solution to this problem, none of my plugins is appearing in the plugin folder, I am again sending you login details.

    Please advise on how to proceed?

    URL - Salsaindia.in/wp-login.php

    Username - [Removed by the staff]
    Password - [Removed by the staff]

  • Nithin

    Hi exist2014,

    Could you please fill me up with the questions that I asked before, so that we could troubleshoot this issue.

    It seems like changing the permissions doesn't tend to work, your PHP settings might be overriding this, would recommend you to keep in touch with your host, and ask to make the default folder permission to 755, and 644 for files.

    Did you ask your host to change the file permissions to 755 for folders, and 644 for files. Current permissions are 705, & 604, as mentioned before changing the permission through FTP doesn't seem to work.

    Also, the wp-config.php in your root folder is missing? Could you please point the location, where you have moved it? I could see a wp-config.php outside your root directory, but there is already another WP installation in that directory. Is that the one?

    Please check this, and advise what I'm missing.

    Please let us know more about it, so that we could troubleshoot this issue. Have a nice day.

    Kind Regards,
    Nithin