Not able to link new top level domail with multi site

I am not able link a top level domain via domain mapping plugin. When I go to the wp-admin page and click on domain mapping from tools menu - and put the domain name to the url to map i ma getting the below error:
DOMAIN NAME IS UNAVAILABLE TO ACCESS.
check your dns records are configured correctly.

I have set up the A record, NS records for the domain in my DNS records with bigrock.in. When I try to ping the domain i am able to ping and it is return the right IP address.

Could you kindly check and let me know.

Bets Regards.

  • Tyler Postle

    Hey Tk,

    Hope you're doing well today and thanks for your question!

    You should only need to setup the A records. Where are you pointing the NS records? If you're pointing that to your host then the A record won't make a difference anymore as now it's not on their name servers.

    Keep the domain on the bigrock.in name servers and just change the A record :slight_smile:

    You can also go into Domain Mapping settings and set "Verify domain's dns" to "No". Sometimes it will think the domain is unavailable when it actually is due to how different domain hosts handle them.

    This setting is located:

    Network admin > Settings > Domain Mapping.

    Is your digital marketing site the one you're doing this with?

    If so, then it looks like the Dedicated IP address's Document Root isn't set so it directs to your multisite install when you visit the IP Address directly in your url.

    If you ask your host to set the Document Root to the root of your multisite install then that should fix that :slight_smile:

    Hopefully the way I explained this didn't make it more confusing. If it did just let me know and I'll be more than happy to help further!

    Look forward to hearing back.

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.