Not able to view site with Membership

I have 3 levels set up for Membership. Visitor (unregistered strangers), Subscribers (people that have registered), and Members (people that have bought membership).
I have 2 subscriptions, a 6 month and a 1 year. Paypal gateway.
I also have Marketpress installed to sell items.
I want visitors to see the store and pages.
Subscribers to be able to comment.
Members to see posts and content in the posts.
I set up access levels for each group.
BUT even when I the administrator go the site I can't access anything. I get the front page only. I click on something I get an error page.
What have I got wrong?

  • DelphiGrafix
    • New Recruit

    Ok, I completely removed wordpress. Made a new directory, installed wordpress, updated it to the latest version and installed Membership.
    I followed the instructions like before and now it works.
    I'm going to add in my other plugins one a time and see if anything triggers the previous weirdness. I'll let you know if I find what I did wrong on the other install.

  • aecnu
    • WP Unicorn

    Greetings DelphiGrafix,

    Thank you for letting us know which is greatly appreciated.

    Sounds like maybe there was a database issue or something with the original installation.

    Happy to see that you managed to get this going as it should be with a fresh install.

    Thank you for being a WPMU DEV Community Member and have a GREAT upcoming weekend!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.