Not activating widget and not keeping options

The plugin behavior is strange: if I try to change any setting after the initial setup, the change is not kept. Including not activating widget.

When I try to turn widget on on opt-ins list screen, the toggle button turns green, but the change is not kept (the widget stays off) and checking the console, I can see "https://www.businessdesign.com.br/wp-admin/admin-ajax.php 500 ()" and the

I am on Dreampress, single site install created a few weeks ago.

  • Rupok
    • Support Ninja

    Hi Celso Bessa,

    I tried to regenerate this issue on my test site but I could not. So this is your site specific issue.

    First of all, I can see that you are using an older version of Hustle. Can you please update that to the latest version?

    Now, thanks for the additional info. Most probably this issue is occurring for your caching. Can you purge all cache, turn of caching and try to make changes and check if changes are staying? I think they will stay.

    And you said you are getting 500 Internal Server Error in your browser console. That's the reason changes are not being saved, and I'm having a feeling that your caching is causing this. Disabling caching probably make your admin-ajax.php work and changes will be saved, I'm not sure though.

    Can you please try this workaround and let us know how it goes? If the issue is not resolved after trying this, please let us know, we will be glad to investigate further. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Celso Bessa
    • Site Builder, Child of Zeus

    Rupok, thanks for replying. I can't turn cache off because Dreampress is a managed service by Dreamhost. So, everything is set pretty tightly and neither me or my client (the site owner) can change those settings.

    Is there anything else, any workaround, I could use to make it work? You see, I am not really happy with Dreamhost support (they will probably tell me it's a plugin problem and they can't help), but my client won't leave them now.

    Thanks in advance.

  • Kasia Swiderska
    • Support nomad

    Hello Celso Bessa,

    Is it not even possible to disable caching for testing purposes? Or is it possible to turn off cache for particular pages?
    Does Dreampress have option to create staging sites that are not using cache (WPEngine has that option)?

    Also would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Celso Bessa
    • Site Builder, Child of Zeus

    Thanks for the response, Kasia. Your answers:

    - it doesn't allow to turn any cache off
    - it doesn't have staging area (love this feature on WPE as well)
    - Sure, already did. My clien client opted for having a simpler mailchimp integration with WPMU Mailchimp Integration plugin instead of waiting for a solution for hustler and we uninstalled it, but i just installed it again temporarily just for you guys take a look into it.

  • Kasia Swiderska
    • Support nomad

    Hello Celso Bessa,

    Is it possible you could get from hosting provider server error log? There should be there all 500 errors - I think we should check those error logs to see what is exact reason of the problem.
    This is long shot but does your hosting has mod_security enabled?
    For now I will deactivate Hustle.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.