Not Assigning Appointments to Provider

Every time I seem to get one thing working with this, I find another thing that doesn't....

When I had only one service provider, it worked okay. I would go in, select a time slot, confirm the appointment, it would get assigned to service provider "shawn", and then when I refresh the page, the spot would be whited out. Everything was great, butterflies were flying, all that jazz...

And then everything changed when the Fire Nation attacked. Or when I added a second service provider, your choice.

So right now, I have two providers, "Shawn", and "Admin", since those are the only two accounts I have. For simplicity, they have separate hours, and I'm only dealing with one day, Sunday.

Admin works from 8am-1pm, Shawn works from 1pm-6pm.

The default 12:30 slot was whited out(not enough time to complete 90 minute service before end of shift), which was good. So I knew it was properly separating them.

I click the 2PM slot, confirm, and get assigned to.... "Our Staff". Refresh the page, the 2 PM slot is still open, no staff member assigned, even though there was only one that could be.

What can I do to fix this? I assume dummy slot would assign everything to whoever I selected in a case like this, but I want it to go to whoever has the hours, and not have to go in and change it all around after someone books.

Additionally, if there are two people working the same schedule, I really don't care who it goes to. But I need it to automatically get assigned to someone that has the open time slot, so if someone else wants that same time slot later, they get whoever didn't have it.

Support access is granted, page is here http://timberhillpainting.com/request-call/

Thanks,
Shawn

  • pxwm

    Hi @Shawn Torsitano

    If I've understood your issue correctly, I suspect you need to setup Working Hours for Admin and set NO Working Hours for 'no specific provider'.

    As I'm not a member of the wpmu staff I can't request login details so would it be possible if you could provide a screenshot of the following tabs:-

    1) 'Working Hours' and select the following from the dropdown:-
    'no specific provider' and take a screenshot
    'Shawn' and take a screenshot
    'Admin' and take a screenshot

    2) 'Services' then take a screenshot

    3) 'Service Providers' then take a screenshot

    Regards
    SteveB

  • Shawn Torsitano

    EDIT: Not sure what happened, but my service hours are different than they were last night. Probably my fault somehow. Anyway, working hours are supposed to be 8am-8pm, admin works sunday 8am-1pm, and shawn works 1pm-6pm, that's how it was last night.

    @pxwm
    I think I know what you're getting at, I'll try turning off regular working hours all together. Guess I'll find out. In the mean time, requested screen shots are provided.

    Given how much help I've seen you provide in my google searches, it almost seems like they should make you an honorary staff member.

    @Nastia

    That was the original option I was considering, however, I have a concern about that. When I select to show times after picking a service or a staff member, the page refreshes. The new information is there, but it's slow and inconvenient. In the situation of there being 4-5 staff members, who all provide the exact same service, it would be a hassle to have to look at each page individually, and click on each calendar day on each page, just to see all the possible appointments available.

    Thanks,
    Shawn

  • pxwm

    Hi @Shawn Torsitano - Many thanks for the kind words and sounds neat idea to be an honorary staff member :wink:

    Many thanks for posting the screenshots.

    Having reviewed I would suggest the following:-

    I always suggest before making any changes that you take a screenshot so you have a fallback option. Even better would be a backup of the site.

    1) 'Services' tab - You currently have each Service set to a capacity of '1'. This may be causing you problems. If I've understood correctly then you have more than one Service Provider assigned to each Service. Therefore I would suggest you set each Service capacity field to zero ')'. This will then default to how many Service Providers have been assigned to offer the service.
    Then Save your settings.
    I always go back and check the settings have been saved

    2) 'Working Hours' tab - This is were I think there is some confusion. Based on your previous posts I'm assuming you want the client/customer to select a Service Provider or maybe you would prefer the allocation of the Service Provider is automatically assigned, but this would involve some bespoke code and then it may only allocate Service Providers in rotation order.
    However for now; your earlier post you indicate 'Admin works from 8am-1pm, Shawn works from 1pm-6pm.'
    Whereas checking your Working Hours screenshot you have set the following:-

    'no specific provider' Working Hours set to 'Yes' everyday 08:00 am to 08:00 pm
    'admin' Working Hours set to 'Yes' for Sunday 08:00 am to 01:00 pm
    'shawn' Working Hours set to 'Yes' everyday 08:00 am to 08:00 pm

    Therefore unless you want a client/customer to book an appointment for 'no specific provider' which will assign to 'no staff' and then you would have to sign-in to admin in the backend and assign a Service Provider then you will need to turn-off Working Hours for 'no specific provider', that is set everyday to 'No'
    Then if you could check the actual Working Days/Hours for Shawn and set accordingly.
    Then Save the settings.
    I always go back and check the settings have been saved

    However if you do the above changes you will have to add the shortcode [app_service_providers select="Please choose a service provider:"] as Natasi has indicated.

    However you can slightly revise both this shortcode and the [app_services] shortcode to auto refresh the page.

    Therefore you could consider revising the 2 x shortcodes to:-

    [app_services select="Please choose a Service" autorefresh="1"]
    [app_service_providers autorefresh="1"]

    When a Service is selected it will auto refresh the page so the Service Provider field should only show those Service Providers that have been assigned to that Service.
    Then when the Service Provider is selected it will again auto refresh the page and show the availability calendar for the chosen Service Provider.
    I do appreciate it would sometimes be nice to choose the Date/Time first and then choose the Service and then only show those Service Providers that are assigned to the Service and available.

    Please let me know if this helps resolve your problem.

    Regards
    SteveB

  • Shawn Torsitano

    Yeah, sorry, I should have clarified the times better. I know the screenshot that I had, had different times than what I said. I think the hours somehow got reset when I was messing around with it, and have since changed them back to the hours I was talking about.

    The issue that I'm having with setting "no specific provider" to "not working", is that it completely eliminates all the time slots for every staff memeber, even when selected individually with the [app_service_providers] shortcode. Essentially the way I see it is that the service providers can't have appointments when the business is closed?

    I changed the service capacity to 0.

    Attached updated screenshots.

  • Shawn Torsitano

    On an additional side note, with [app_service_provider autorefresh="1"], it provides me with the drop down menu with the names. However, the select button is still there, and does absolutely nothing when I try to pick a name. It doesn't refresh the page, or change the calendar.

    Service select auto refreshes the page, which would still cause the problem I mentioned earlier, where people would spend way too much time waiting on page refreshes and trying to remember the available times for all employees, which isn't a huge deal with 2 employees, but will be problematic when I expand to 4-5 in a few months.

    Selecting a service provider doesn't change anything with the argument autorefresh="1" removed either.

  • pxwm

    Hi @Shawn Torsitano

    Many thanks for the feedback and the new screenshots.
    I'll try and cover all your points.

    Just to confirm should the Working Hours for Admin be Sunday 08:00am to 01:00pm and for shawn Sunday 01:00pm to 06:00pm?
    I ask because the Working Hours screenshot for shawn still shows everyday set to 'Yes'

    I can confirm that you don't need the Working Hours set to 'Yes' for 'no specific provider'.
    It should work fine just setting the Working Hours for each individual Service Provider.

    Just out of interest could you confirm if you have any exceptions set up in the 'Exceptions' tab?
    Could you please check for each Service Provider.

    Is it possible you could provide a list of all your shortcodes in your Appointment page so I can check.

    Could you also confirm which Add-ons you have activated.

    As for long page refreshes, I've never experienced this problem nor the problem with client/customers selecting suitable Date/Times for each Service Provider but my site is on a VDS and not on shared hosting.

    As previously mentioned I think it be a great enhancement to the plugin to provide the option for the client/customer to select the Date/Time they wish to book and then it provides those Service Providers that are available.
    However I would suggest this would have its drawbacks.

    I hope this helps and I'll look out for your reply

    Regards
    SteveB

  • Shawn Torsitano

    Right now Shawn is set to all days, but I've been confining my tests to sunday for simplicity. The current hours aren't anywhere close to what they will be when I start actually working. So, yes, for clarification, it's currently all days, but I haven't been doing anything except on Sunday.

    Do you know of a setting related to working when "no specific provider" is set to no? Because once I set it to no, all the green "open" days on the calendar went away, despite both service providers still being set to "yes" for the days.

    There are no exceptions in general, or for anyone in specific.

    Shortcodes:
    [app_services autorefresh="1"][app_service_providers autorefresh="1"][app_monthly_schedule][app_confirmation button_text="Book Appointment!"]

    I'm still not having any luck with the service providers short code working. It's not refreshing the page automatically, when I press the button, or when I press the button after removing "autorefresh".

    Thanks,
    Shawn

  • pxwm

    Hi @Shawn Torsitano

    Many thanks for the additional information.

    Having checked this information and your screenshots and checking your site I think you have a conflict on the page with your show/hide.

    Having checked your page: http://timberhillpainting.com/request-call/ then selecting 'Schedule and estimate' it shows the calendar.
    However when I select a Service it refreshes the page and resets the show hide so you have to select 'Schedule and estimate' again.

    I would suggest you need to change your javascript, if that is how you have created your show/hide so it retains the page showing the calendar.

    Maybe to prove if it is a conflict with your show/hide code could you, as a temporary fix, remove the show/hide code so as soon as you navigate to the http://timberhillpainting.com/request-call/ page it shows the calendar to see if this resolves your problem.

    I hope this helps
    Regards
    SteveB

  • Shawn Torsitano

    @pxwm

    I'll pull the calendar out of the drop down if you think it might be causing a conflict, and test it from there. It hasn't made a difference any of the previous times that I've tried it, but I'm open to trying it again.

    As far as interfering, earlier in the testing process, I made it so my employees offered different services, and when a service was selected and the page refreshed, the calendar successfully changed to reflect that, even inside of the drop down.

    As far as how it was made... I'm unfortunately inept with coding. Hardware has always been my main computer concentration. I'm assuming it may have been made with JS, but I just used some shortcodes that were provided with a shortcode plugin that I have.

    Having moved the calendar outside of the drop down, all the days are still whited out. If I set "no specific provider" hours to "yes", they turn green again, which we were talking about earlier.

    Is there a private messaging system on here? If you're cool with it, I'd like to make you a temporary admin account on my site. I'm sure it would be a million times easier for you to sort through issues that way. I always hated trying to diagnose computer problems over text.

  • Shawn Torsitano

    So, some very delayed updates. Steve was a huge help, and took a lot of time and effort to help me solve my problem, so thanks a ton to him for that.

    What we eventually ended up with was that we could only get a functioning calendar if the shortcodes were inserted into a new page in the standard WordPress editor. So he created a new page, I just sucked it up.

    Then there was that update, and I figured I would try to see if the update fixed the issue. So in Upfront, I created a new text box, copied the shortcodes in, and on the page I had two functioning calendars, the original one from the standard editor, and the new one via Upfront.

    I assumed that whatever was in the update fixed the issue. I deleted the region that had the original calendar in it, because that is the only way I've found to get rid of those(they don't have a red x to close it, as in things done in the original page editor, not specifically the calendars), and moved on.

    Yesterday though, I accidentally hit the wrong edit button on my appointments page, and it took me to the standard Wordpress editor. I noticed I forgot to remove the short codes in there, so I did. All the sudden, the calendar wasn't working anymore.

    So, in summation, what I discovered was that, in order to have a functional calendar inserted with shortcodes in a text box in Upfront, you have to have the exact same code in the standard Wordpress page editor. As long as you delete the region with the original calendar, you won't end up with two on the page.

    It seems like the calendar from Upfront is dependent on the other one, somehow. I made a temporary change to the title for both this month and next month calendars in Upfront, but only made that change to the first month in the page editor. Only the first month had the changed title.

    So I guess for all intents and purposes, the issue is solved for me, but I figured I would provide more information on the chance that this is something someone wants to look into. As an aside, disabling all my plugins before did not cause any change in functionality, but I don't feel like taking the time to do it a second time to verify.

    Thanks,
    Shawn

  • Nastia

    Hello there Shawn and Steve!

    I hope you are both well!

    My apologies for late reply, this ticket must have slipped out from our feed!

    Shawn I could not recreate the same issue on my sandbox setup. I created two service providers, set up same working hours, and a service for 90 min. The short-codes are the following:

    [app_services ... select="Please select a service:"]
    [app_service_providers ... select="Please choose a service provider:"]
    [app_monthly_schedule]
    [app_confirmation ... title="Please check the appointment details below and confirm:"]

    I noticed I forgot to remove the short codes in there, so I did. All the sudden, the calendar wasn't working anymore.

    What short-codes have you removed from the appointments page?

    The following short-codes worked normally on my site as well:

    [app_services autorefresh="1"]
    [app_service_providers autorefresh="1"]
    [app_monthly_schedule]
    [app_confirmation button_text="Book Appointment!"]

    One of the main fixes in the Appointments+ new version were:

    Worker is not selected automatically by default and timetable displays wrong times in some rare cases

    There is a possibility that you had this specific rare issue.

    It seems like the calendar from Upfront is dependent on the other one, somehow. I made a temporary change to the title for both this month and next month calendars in Upfront, but only made that change to the first month in the page editor. Only the first month had the changed title.

    Please create a separate ticket regarding this issue. Someone from our staff will take a look to it ASAP.

    @pxwm,
    Steve, thank you for your time and devotion to our members. I will inform our developers about this, but I would prefer to troubleshoot more the Shawn's installation to get to the bottom of this.

    Shawn, id you still have this issue or will have in the future, please feel free to reopen this ticket. I'll be glad to have a look!

    Kind Regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.