Not Backing up

I get a message "You don’t have any backups. Run a backup now." I click on the link "Run a backup". Nothing happens. Then, I tried to "Enable scheduled backups", click on the Update Setting button. But, when I return to the hub, it's disabled.

  • Ash

    Hello Uy Creative

    There is possibility to have an error on the backgroun. Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Now, from your dashboard > Snapshot > Managed Backup > And try to take a backup now. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    Besides, would you please enable support access so that I can check, if needed? Please follow this article to enable support access: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Have a nice day!

    Cheers,
    Ash

  • Uy Creative

    Okay, I was able to get it to backup and to schedule a backup. Although, I have still have a couple questions. I did change wp-config.php, as suggested. Then, tried to run the backup. But, I never saw the debug.log file appear in the wp-content folder. Shouldn't that have shown up? The second question is. I have the scheduled backup set for 3am daily on the site. But, on the hub, it says 8am. Is there a time setting I need to change on the hub? I left support access open, in case you would like to view it.

  • Ash

    Hello Uy Creative

    Although, I have still have a couple questions. I did change wp-config.php, as suggested. Then, tried to run the backup. But, I never saw the debug.log file appear in the wp-content folder. Shouldn't that have shown up?

    The debug.log file will appear if any error is produced, otherwise not :slight_smile:

    The second question is. I have the scheduled backup set for 3am daily on the site. But, on the hub, it says 8am. Is there a time setting I need to change on the hub?

    Would you please make sure that you have exactly same time zone in Dashboard > Settings > General > Timezone and Timezone tab in here: https://premium.wpmudev.org/hub/account/ ?

    Let me know if it works :slight_smile:

    Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.