Not being routed to confirmation page

I set a separate page for people to be routed to once they made an appointment, to track as a GA goal, but that is not happening. Instead there is a pop-up.

I used Appointments > Settings > Accessibility > Appointment thank you page and selected a page I created from the drop-down list.

  • Dimitris

    Hello WPMonkey,

    hope everything's fine for you! :slight_smile:

    http://musicologystore.com/music-lessons/ has this issue and shortcodes were added in the Upfront editor.
    http://musicologystore.com/music-lessons/make-an-appointment/ does not have this issue and shortcodes were added via the WordPresss editor.

    So, the real problem occurs whenever you add the shortcode from the Upfront editor only? This shouldn't have much difference though...
    I tried to replicate it in my local end, but I didn't. I successfully inserted my shortcodes inside a text element through the UpFront editor, and after choosing an appointment, I had a success pop-up and then I redirected into the page that I had set as Thank You page.
    Despite that, is it a working solution for you the second page you posted? You can always have your shortcodes in post content (via WP editor) and use this through the Post Data element (as I suppose you already did).

    Please advise,
    Dimitris

  • WPMonkey

    When you looked at the pages did you see any key differences? I'm just reporting all the information I have, but that shouldn't stop you from investigating further.

    So, the real problem occurs whenever you add the shortcode from the Upfront editor only? This shouldn't have much difference though...

    The main issue is that the Appointments+ plugin on http://musicologystore.com/music-lessons/ is not working as it is supposed to. Appointments are not being assigned to service providers, notices are not sent to service providers, and I'm sure there are more issues that I haven't discovered yet. I happened to notice that this was a page edited in Upfront, while I created another page only in WordPress to test some of these issues and found that they didn't seem to be on the WordPress page.

    Please investigate further, I would prefer to use the Upfront page and now we have had to push back our go live date until this is resolved.

  • Dimitris

    Hello WPMonkey,

    hope everything's fine for you today! :slight_smile:

    When you looked at the pages did you see any key differences?

    No, I didn't observe any key differences between pages, just couple of shortcodes that were missing from /music-lessons/, [app_login] and [app_paypal], but I don't believe these are necessary (forgive me if I'm wrong here, another test could make things clear). Despite that, I placed them in /music-lessons/, before and after the confirmation shortcode, just like it is in /music-lessons/make-an-appointment/ content.

    The second page you created, you made it using the Create an Appointment Page option located in /wp-admin/admin.php?page=app_settings#section-display, right?
    This is the safest way of having a page with all the elements needed by A+. And you can still edit that page from UpFront editor, well, apart from the fact that all of your shortcodes will be included inside the Post Data element. But other than that, you can still edit the rest of the page. :wink:

    My main concern now is that it seems the shortcodes from A+ plugin, don't render successfully only when they're placed through the Upfront editor? That's definitely something that I can't reproduce in my local test installation. Said that, would you mind placing some appointments through your site? I believe that you could easily skip those as will use your own administrator email through the Support Staff Login that you have granted us.

    Warm regards,
    Dimitris

  • WPMonkey

    My main concern now is that it seems the shortcodes from A+ plugin, don't render successfully only when they're placed through the Upfront editor? That's definitely something that I can't reproduce in my local test installation. Said that, would you mind placing some appointments through your site? I believe that you could easily skip those as will use your own administrator email through the Support Staff Login that you have granted us.

    I don't understand what you are saying here. I added shortcodes to http://musicologystore.com/music-lessons/ in Upfront and the service providers are not pulled into the confirmation dialog, service providers are not sent emails (and they need to be, not only the admin), and customers are not routed to a thank you page as set in the settings. These are functionality errors. Please forward this to development to look at so they can possibly fix it.

    Said that, would you mind placing some appointments through your site?

    I've placed dozens and dozens on both pages, so I don't understand why are you asking this. You can see them in Appointments, and you can place some right now before we go live. Please do, on both pages.

    I believe that you could easily skip those as will use your own administrator email through the Support Staff Login that you have granted us.

    I don't understand this? Are you saying that email notifications to service providers should be "skipped" and doesn't work and that I as the website administrator should manually forward the emails I receive to my client's instructors? I'd rather that the feature works.

  • Dimitris

    Hey there WPMonkey,

    please excuse me for the miscommunication here, I'm trying for the best and to get things as clear as can be. :slight_smile:

    There seems to be a lot of miscommunications and back and forth on this issue that is not addressing the root of the problem.

    What I meant was to place some appointments as I couldn't replicate it in my test installation for both ways, having a page created and edited through Upfront and having it created in the backend WP editor.
    I asked you in case this is a live URL with customers and you may don't want to interfere, at least like this. Now, by granting us support access, I can login like your admin account, so if I book an appointment you should be able to see that like it was you that placed it ("...will use your own administrator email... ":wink: and so you could easily skip it (wrong word maybe... let's say 'remove' it).

    I reached your site again and placed couple of appointments now from both pages (I already removed those as you can see in http://musicologystore.com/wp-admin/admin.php?page=appointments&type=removed).

    So, using http://musicologystore.com/music-lessons/, the page created by Upfront in which A+ shortcodes are used, I got the appointment send successfully to the backend with two errors:

    1. service providers are not set, and therefore, not getting any notification email
    2. page doesn't redirect to the Thank You page

    The generated error is the following:
    app-confirmation.js:198 Uncaught ReferenceError: app_location is not defined

    I just informed our developers about that misbehaviour and I'll keep you posted as soon as I have some more info on this.

    Thanks as always,
    Dimitris

  • Milan

    Hello Brandon

    Hope you are well today and thanks for pinging us here about your issue.

    Though it seems similar but its always good practice to open new thread for your issue as server configuration and many other things wont' be exactly same as this thread's creator. Its my humble request to you that you open new thread for your this issue and I am assuring you that as soon as your open new thread, one of our staff person will jump on it to assist you further. :slight_smile:

    Thanks a lot for being with us. :slight_smile: Have a good day. :slight_smile:
    Best Regards,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.