Not creating users

I cannot begin to tell you how much I loathe this plugin. I've been trying to use it on several sites for several months, and it rarely works as expected. The errors mesages are not very useful - they don't give enough information - just that something hasn't worked.

Some users are created and some not - and no reasons are given for the failure. Some more detailled error messages would definitely help us create useable CSV and XLS files for upload.

Now let me come to the current problem. (WP 3.1.2, BP 1.2.8 - batch create 1.1.2)
I have a CSV file that I have uploaded to the admin interface for Batch Create - no problem.
Message "item added to cue"
Fantastic!
You'll see in the screen shot: Instructions point 4: You need to click on the link 'here' in 'Click here to process the queue.'
Please see screenshot to notice that there is no link to click to process the queue!
Helpful
Oh - but I can clear the log file....

Please help. This plugin is painful. It would be a joy if it worked reliably.

  • Ajax McKerral

    Hi masonjames and Phil,

    Thanks for the response, I'm not really happy posting my users email addresses to a public forum, but am happy to email them through.

    Regarding log files - these should be in the plugin's folder, yes? (/wp-content/plugins/batch-create)
    Because I can't find anything there.

    The folder is owned by group www-data, and has permission 775, so the web server should be able to write files to that folder...

    I eventually used the Invite-anyone plugin for BuddyPress, to invite the users to the group.

    But I would still like to use batch-create in the future, so solving this issue would still be useful.

    Regards

    Ajax

  • Vladislav

    Hello,

    The status message ("Items added to queue...") seems to be misleading in this context, since the missing "click here to process the queue" indicates that the queue is empty.

    If I understood your post correctly, you were uploading a CSV file. Unfortunately, if you haven't created you CSV file by hand it is quite possible that some character other then comma is used as field separator. Batch Create is pretty literal in its interpretation of what exactly is a CSV file and how to handle it, and it won't parse CSV files that are separated by, say, tabs or semicolons.

    Can you please verify that your CSV file is actually a comma-delimited (rather then tab- or semicolon- delimited) file? Better yet, can you please save your data in Excel 97-compatible format (plain old xls) and try to upload that file instead?

    I agree that the plugin should have better status/error reporting. I'm working on that for the next release, which will be as soon as we verify that the plugin works correctly with input files it understands.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.