Not displaying site style (logo, CSS) in search results

Hi - I just implemented this on my site, but it's not styling the results as per my site design (logo is missing, no other style). See for instance http://www.superguide.com.au/?s=work+test

Also, with the 'Custom Google Search' widget, is there any way to switch off the auto-complete? It makes it very hard to see what is being typed. Please note that this is at the bottom of my sidebar, on my home page only - http://www.superguide.com.au

Thanks in advance.

Cheers, Rob

  • PC

    Hiya,

    Just configured the plugin out of the box and it works fine

    http://wpdemo.in/?s=test

    It shows up with my theme without any issues.

    I also tested it with the widget and asked the widget to show results on the search page instead of the pop up.

    I also noticed that your template is breaking up when I am using the top search bar so it looks like your theme search code is over riding the template. Can you please try and use the widget and set it to show the search results on a search page and see if you still see the same issue ?

    I will also request you to use it with the default theme to see if you notice the same.

    Cheers, PC

  • robertbarnes

    Hi PC - Thanks for your response.

    It is the same issue when I use the widget and set it to show the search results on a search page.

    I am not going to switch to a default theme - this is my live site.

    Please can you explain what you mean my template is 'breaking up when I am using the top search bar'? If there is information I should pass on to my theme developer then I will.

    It seems to me that the configuration instructions are not very clear, and should be more detailed. Please can you confirm exactly what code I should be entering in the 'Embed Code/Search ID:'. I am just putting in "014094977042833441616:ct9dflcvnzk" (I have changed some of this for security).

    There are practically no instructions - I think it needs to be clearer about
    a) since it's either the search ID OR the embed code, if the search ID isn't working, which part of the embed code should I put in the box on /wp-admin/options-general.php?page=custom-google-search-settings - (I have tried all variations, the same result).
    b) are there any settings I need to make with my theme?
    c) do I need to create a 'search results' page by using a template?
    d) what settings should I be making in the Google admin.

    Cheers, Rob

  • PC

    I am not going to switch to a default theme - this is my live site.

    In that case, can you please send me a copy of the theme you are using so that I can test it on my lab site ?

    Please can you explain what you mean my template is 'breaking up when I am using the top search bar'? If there is information I should pass on to my theme developer then I will.

    On your site there are 2 options where I can search. One search bar is at the top of the site and one is at the bottom. The bottom one is using pop up search.

    It seems to me that the configuration instructions are not very clear, and should be more detailed. Please can you confirm exactly what code I should be entering in the 'Embed Code/Search ID:'. I am just putting in "014094977042833441616:ct9dflcvnzk" (I have changed some of this for security).

    There is no complex setting apart from what mentioned here : https://premium.wpmudev.org/project/custom-google-search#usage

    I have attached a screenshot of what I am using on my lab site.

    Due to the lack of support on this I'm going to have to stop using this plugin. Really disappointing.

    My membership is due for renewal in a few days, but I won't be renewing.

    That is certainly not lack of support Robert. I am just trying to help you out here and the best I can do is provide suggestions and test them out on my lab site. There is no way I can fix it remotely without understanding what is actually going on.

    Thanks for the rating and I will wait for a copy of theme files so that I can test it on my lab site.

    PS : I will suggest you to have a test site of your own as if you are running a live site, its always good to test things out on a test site before making them live.

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.