Not getting the option to upgrade Membership Pro

I have three multisite installations that use Membership Pro on some sub-sites. I do not have the plugin Network Activated because some sites use it while others do not. The issue that I'm having is that I am not getting the link to update the Membership Pro to Membership 2. I have tried using "Update Now" on the Updates page on the WPMU Dashboard - multiple times on all three sites - but I can still not upgrade. Is this related to the fact that Membership Pro is not network activated? If so, how do I upgrade? I can't use the Membership menu on the Network Admin dashboard becausethe plugin is not Network Activated.

On two multisites (including my test site) I am just deactivating and deleting the old Membership plugin and installing the new one. But on the third site, which uses Membership on basically every site, I was considering Network Activating the plugin and then trying to run the Update Now link again. Do you think that will work?

  • Adam Czajczyk

    Hey @dmuchnok

    I hope you're well today and thank you for your question!

    Being logged in as a super-admin you should see the "WPMU DEV" dashboard on each sub-site and also you should be able to upgrade I think. However, it's possible that non-network activated Membership prevent this from happening. I must admit I haven't encountered such a case before.

    That said, I think Membership 2 Pro has to be installed through Network Admin, via WPMU DEV dashboard. If you don't see an upgrade message, please make sure that you're running the latest Membership Premium version which would be 3.5.3.3 and could be downloaded directly from this post.

    If this is not a case then you may want to try simply removing the Membership plugin folder from /wp-content/plugins/ folder (but not removing plugin via your dashboard) and then trying to simply install it via WPMU DEV dashboard.

    I'd strongly advise though to make a full backup of your network first (including database).

    Let me know if it worked for you, please!

    Cheers,
    Adam

  • dmuchnok

    Hi Adam,

    I was using the WPMU Dashboard, so I just uninstalled the old Membership plugin and installed the new one. It seems to have worked OK, I even got to run the update on sites that had Membership already installed.

    The problem is going to be when I try to upgrade the the plugin on a site where I use it extensively. When ever Membership is installed on a multisite and it is NOT network activated, I do not get the Upgrade option in the dashboard.

  • Adam Czajczyk

    Hey Dan!

    Thanks for your replay!

    I understand that you're having trouble upgrading on Multisite install with "per site" activated plugin but have you tried already the procedure that I've suggested in my last post?

    Although in this case the plugin is not network activated it is actually "network installed", meaning that the plugin and its files are exactly the same and are placed in the same location.

    The only drawback here would be that you would have to manually disable the plugin on all subsites, then follow the procedure via Network Admin and once it's done activating the new one again on every sub-site.

    It would of course be great if you could first make a full backup of your network "just in case" but I think it should work fine.

    Kind regards,
    Adam

  • dmuchnok

    HI Adam,
    I did try the method you suggested on my test multisite, with one twist. After I deactivated the plugin on all active sites, I deleted the plugin files through the dashboard, rather than deleting the folder manually. That method seemed to work just fine as well, and in fact, it forced me to run the update script when I activated the Membership2 plugin on the old sites.
    I will definitely make a backup on the production site before I do this, but fortunately, I am not running the Membership plugin on very many sites. The first big one is being developed now and I wanted to start with Membership 2.
    FYI, it's probably something that should get some attention. I can't believe I am the only person with this issue - but it is definitely an issue on three different mutisite installs.

    Thanks,
    Dan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.