not HTTPS / SSL compatible

at wp-login screen, I get security errors. turns out it's because this plugin is activated and includes this code:

<script type='text/javascript' src='http://example.com/wp-content/plugins/comments-plus/js/comments.js?ver=3.3.1'></script>
<script type='text/javascript' src='http://example.com/wp-content/plugins/comments-plus/js/twitter.js?ver=3.3.1'></script>
<script type='text/javascript' src='http://example.com/wp-content/plugins/comments-plus/js/facebook.js?ver=3.3.1'></script>
<script type='text/javascript' src='http://example.com/wp-content/plugins/comments-plus/js/google.js?ver=3.3.1'></script>

1) why are these scripts loading at wp-login?
2) please make plugin compatible with SSL / HTTPS

3) this might be from this plugin as well - another thing to be fixed:
<script type='text/javascript' src='http://platform.twitter.com/anywhere.js?id&v=1&ver=3.3.1'></script>
If not from this plugin, it's surely from another WPMU DEV plugin.

Thank you.