Not linking correct urls for member content

Currently I am not able to get my members to the correct URL to download a pdf. When I am logged in as admin (www.mysite/wp-content/uploads/2013/09/filename, it works correctly, though when logged in as a member, it tried to link to http://www.mysite/2013/09/filename, thus they cannot access the file.
Originally I had tried to protect the downloads using the masked URL but couldn't get it to function properly. Have since deleted the masking categories and access limitations. Should I re-install or something?

  • Vaughan
    • Support/SLS MockingJay

    hiya

    you need to add the downloads to the access rules.

    1st create a protected url group, then add the url to this group (screenshot 1)

    then add this group to the downloads / media in dashboard > membership > options > downloads/media tab (screenshot 2)

    then add this url group to your access rules to allow or deny. (screenshot 3)

    it will only protect files that are upload via the media manager, it will not protect files uploaded manually via FTP

    hope this helps

  • Hayley
    • New Recruit

    Thanks for the instructions for the url protection. I may try to protect the downloads again at a later date, but in the meantime I just want the links to work without protection. Do you know where the "wp-content/uploads" portion went for members and why it will no longer link to the file?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.