Not logged in on Mapped Domain

I am sorry this seems to be a bit of a repeat, but the previous thread related to the problem was closed, and yet, I am experiencing it on the latest version of the plugin (4.1.2).

Basically, I have mapped a domain to a subdomain on my Wordpress Network. All seems to be fine with that part, and no issues accessing the Dashboard. The problem is that the admin of the site with the mapped domain appears to not be logged in when viewing their own site. No Admin bar at the top, and unable to do things one should be able to do in Wordpress when logged into their own site.

I believe I have tried every possible setting combination, but am willing to try more. Please advise how to solve the problem!

Thank you.

  • Dan
    • Site Builder, Child of Zeus

    Hi Jack,

    Sorry been preoccupied with the Summit Kilimanjaro competition, but it's looking like I will be getting through to the next round! (http://thesummit.co/kilimanjaro/nominees-alpha#entry-76)

    Anyway, unfortunately, on the same server I have site related to medical laboratories, so for privacy reasons I cannot give you FTP access. But I can give you admin access. I assume you need Super Admin?

    Let me know,

    -dan

  • aristath
    • Recruit

    Hello again!

    I just logged-in on your site and took a look at your settings...
    If you go to Network Admin => Settings => Domain Mapping, you'll see a setting called "Cross-domain autologin" (see attached screenshot).
    Can you please try setting that to yes and test this again?
    Please note you might have to reset all caches and your browser cookies before you actually see that setting in effect.

    Let me know if that helps!

    Cheers,
    Ari.

  • Dan
    • Site Builder, Child of Zeus

    @@adminAristath Thank you for looking into this!

    Unfortunately, that does not help. Checking that box has no effect if a user is not logged in to the network, but if the user is logged in, when visiting the site it ends up in a loop. What I mean by that is that my browser shows it repeatedly "Waiting for primarydomain.com" and then "Watiing for mappeddomain.com"

    Also, forgive me if I understood the setting wrong, but does that setting not imply that a user that logs into mappeddomain1 would also be logged into mappeddomain2?

    This would be very problematic for me as I have different customers that have nothing to do with each other. So mappeddomain1 users should not even necessarily know about mappeddomain2 and even less so be logged into it.

    Let me know if there is anything else I should test!

  • Dan
    • Site Builder, Child of Zeus

    Hi @Jack!

    Well, I tried, but it made no difference. Other suggestions?

    Should I be finding a different domain mapping plugin? I'd rather not, as I like the option to sell domains, but this isn't really working.

    Well, let me know!

    -dan

  • Sam
    • The Incredible Code Injector

    Hello @Dan

    Please upgrade to latest version, clear browser cache and cookies, login and make sure single sign on is active.

    If redirect look persists, please grant staff access so that I can take a look

  • Dan
    • Site Builder, Child of Zeus

    @Vaughan done!

    @Sam: upgraded, cleared browser cache and cookies. and set Yes for users to be logged in across network (assuming that is what you meant by single sign on). The result was a loop between "Waiting for MappedDomain.com" and "Waiting for PrimaryDomain.com" without ever resolving.

    I set it back to not being logged in across network, but this clearly is also an issue, I assume it is related. You now have support access, let me know if you need me to run other tests.

    This is the last big obstacle for me to overcome to launch a beta, so I really appreciate all the help you guys are giving me!

  • Sam
    • The Incredible Code Injector

    @Dan
    Thanks for the access permission.

    Please visit https://premium.wpmudev.org/contact/

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    - Mark to my attention - ATTN: Sam Najian
    - Link back to this thread
    - Include admin/network access
    - Include cPanel (I will need to look at the DB so need PHPMyAdmin or similar)
    - Include FTP
    - Include any relevant URLS for your site

  • Dan
    • Site Builder, Child of Zeus

    Hi Sam, Sorry, this ended up getting lost in the shuffle, and my project got put on the back burner till now, but I am now back at it.

    Should I go ahead and do the above still? I am noticing that in spite of the many updates recently to the Domain Mapping plugin, I still am not shown as signed in on a mapped domain.

    Thanks, and sorry again for the significant delay.

    -dan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.