Not receiving mail from contact forms

Hello,

I have some forms set up on my site and they for some reason will not send email to certain email addresses. I am using the plugin Contact Form 7 but I do not believe it is an issue with the plugin.

The emails I am trying to send to are Google Accounts so I am not sure if that may be a problem.

Here is what I have tried:

Searching for bugs for Contact Form 7
Changing my DNS MX Records to point to the correct Google one.
Using the WP SMTP Mail plugin.

It seems to only cause an issue when I change the email to send to to be that of the same domain. So if my domain was example.com then test@example.com would not go through. However, test@test.com, test@blah.com, test@whatever.com would all work perfectly fine.

I have tried really hard to find out what is going on and can't seem to find the underlying issue. Anyone that helps is greatly appreciated!! Thanks in advance!

  • Philip John
    • DEV MAN’s Apprentice

    Hiya!

    Who are you hosting with?

    It sounds like your server is set up to handle mail internally somewhere. Hence any e-mails the server tries to send to example.com aren't pushed outside of that server.

    You should try contacting your host to explain the situation to see if they can provide any guidance on why the server is over-riding the MX records.

    Cheers!
    Phil

  • mmedia
    • The Incredible Code Injector

    Hello,

    Thank you for your response. I am using Media Temple as the host. I thought that was an issue also so I made sure that it is not set to "local mail", and then thats when I changed the DNS MX records. It is looking like I may be giving them a call on this issue though as I still have not found anything new about the situation. Once again thanks for your response, and if you know anything about Media Temple mor input is always welcome!

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.