Not Secure; Visual Compser

Whenever I sign into my site it says: Not Secure. Is there a way to secure my site?

Also, before signing up with wpmudev, I used to have access to visual composer in addition to the "classic" form of page editing. Is there a way to get this fuctionality back, or does it now require me purchasing a license?

  • Predrag Dubajic

    Hi Robert,

    Not Secure message means that you don't have SSL certificate on your site and it's loading over HTTP protocol instead of HTTPS.
    Check with your host if they offer Let's Encrypt or another type of SSL certificate and once you have your site working over HTTPS the error should be gone as well.

    Also, before signing up with wpmudev, I used to have access to visual composer in addition to the "classic" form of page editing. Is there a way to get this fuctionality back, or does it now require me purchasing a license?

    I'm not sure that I understand this question completely.
    We are not affiliated with Visual Composer and our plugins shouldn't be affecting their licensing in any way.
    Visual Composer does come with free and premium versions and free one doesn't require any license from what I know.

    Can you explain a bit more what is exactly the difference that you're seeing and which option you are missing, perhaps attach a screenshot?

    Best regards,
    Predrag

  • Robert Loeffler

    Predrag,
    Attached is a screenshot of my "Pages" > "For Sale"

    This is what I see when I switch to visual composer mode. I am looking for the old mode where I could move columns and switch out photos by clicking on a red X and selecting new images from my media which would make it a green checkmark. It had a pencil icon for editing images and blocks. How do I get this functionality back so that I don't have to enter the html code and use mostly my mouse?

    Thanks,

    Bobby Loeffler

  • Adam Czajczyk

    Hello Robert Loeffler

    What you see is Gutenberg editor. It's not related to WPMU DEV but to the WordPress update. The Gutenberg editor was introduced some time ago but was included in WordPress and replaced its default editor with the WP 5.0 release. Since then it's the default editor.

    The Visual Composer should work with it anyway. I'm not sure what version of it are you using but here's what you might try:

    - go to the "Visual Composer -> Settings" page
    - in "Post Types" section make sure that the toggle switch is set to "ON" for "Page"
    - (optionally) set toggle switch to "OFF" for "Gutenberg" there

    Give it a try and let me know, please, if it helped :slight_smile:

    Best regards,
    Adam

  • Adam Czajczyk

    Hi Robert Loeffler

    Thanks for information.

    Unfortunately, I'm not sure what to try next as I'm not sure what exact plugin and its version are you using. There's a Visual Composer plugin (free and premium - and those are slightly different) and the WPBakery Page Builder plugin formerly known as Visual Composer (which is actually a different thing). Based on this screenshot I can assume only that it's either some older version of WPBakery Page Builder or it's some "spin off" of any of those.

    I'd be happy to take check it though. Would you mind enabling support access to the site so I could do this? To do so, make sure that you have our WPMU DEV Dashboard plugin installed, enabled and logged in into your WPMU DEV account and then simply go to the "WPMU DEV -> Support" page in your site's back-end and click on "Grant support access" button there.

    Once that's done, let me know here and I'll access the site, check exact plugin and its settings and see what's happening. I believe we can sort it out that way.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.