Not sending Notification & Confirmation Emails

My website is offering 2 types of content
1. for non-registered members - limited property sales info
2. for registered members - full property sales details

What I'd like to happen is...
1. User registers on the website.
2. Membership automatically gets approved.
3.a Email confirmation is sent to the user + login details.
3.b Email notification is sent to the admin + user registration details.

I've been able to achieve #1 and #2 by using the shortcode [ms-membership-register-user membership_id="xxxx"] which I saw from another thread.

The problem is the site is I can't make #3.a and #3.b work.

I am currently using WP-Members to customize my registration form, dialogs and emails.

Another problem is that the registration page looks stupid because it asks the user to enter his names 2x and password 4x.

Finally, I cannot make the captcha from the WP-Members plugin work. It used to work when I was not using the [ms-membership-register-user membership_id="xxxx"] shortcode.

You will also notice a bunch of redirects because I don't want users to go to the Protected Content Site Pages (Memberships, Account). If there's a way to skip those I'd prefer not to use any redirects.

I've enabled wpmudev support access because I don't know what else to do. Thanks so much for your help!

  • Tyler Postle

    Hey Aussie,

    Hope you're doing well today!

    I'm getting a "server not found" error when I try to login to your site so I'm not able to check your settings. Looks like your site might be down right now.

    However, I think i might still know the issue here. Do you have the "free membership" email turned on? You will need to activate the "Additional Automated Messages" add-on first then go to:

    Protect Content > settings > Automated emails and select the free membership one as seen in my screenshot then toggle it on :slight_smile:

    If that's still not fixing the issue for you then when your site is back up could you post back so we can have a closer look?

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back!

    All the best,
    Tyler

  • Aussie Brokers

    Many thanks for your prompt response, I really need to get this site live in the next 12 hours.

    I don't have the free membership email template as you've shown me in your screen clipping. Please take note that I've already created 50+ pages with the shortcode for content protection so in case you need to make changes, kindly ensure that the changes won't affect the existing content protection.

    You will need to place the entry below in your computer's host file.
    Host Entry
    216.70.82.36 http://www.test.aussiebrokers.com.au test.aussiebrokers.com.au

    A detailed screencast is available for both Windows and Mac:
    For Windows use <http://websynthesis.com/screencast/host-window/>.
    For Mac OS use <http://websynthesis.com/screencast/host-mac/>.

  • Aussie Brokers

    I've been able to add the free email template via the add-on section. The email notifications are now working both for the user and admin. However, I am frustrated that the custom data fields from my registration form are not captured anywhere -- not in WP, not in the user profile, and not in the emails. Please help me make it work. Also, the other issues like duplicate name and password fields in the registration form and missing captcha are still unresolved. Looking forward to hear from you again. Thank you!

  • Tyler Postle

    Hey Aussie,

    Thanks for your reply.

    We don't have any integration between WP-members and PC registration, which is why you're running into issues here. If you're wanting to add custom fields to the PC registration then you will want to use BuddyPress - we've added integration so you can use BP's registration and add custom fields through it's Extended profiles component.

    Another option would be to use the "default" membership in Protected Content. So instead of adding the shortcode for the default membership you just create a default membership that is applied to every user that signs up on your site :slight_smile: which is what it sounds like you are wanting to here.

    To setup the default membership go to:

    Protect Content > Memberships > Create new membership > Default membership.

    This will be applied to every current and new user that doesn't have a membership yet.

    Let me know if that method would work instead :slight_smile:

    I'm not to familiar with WP-members as I haven't used it before, but it looks like you will need to use their shortcodes to display the field data to the user, like this:

    [wp-members field=”first_name”] - they have more shortcodes here: http://www.butlerblog.com/wp-members/users-guide/shortcodes/

    Hope this helps!

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.