Not Showing Available Subscriptions After Update to Membership 3.5.1.1

Hi guys,
I just updated to Membership 3.5.1.1 and I noticed that the subscriptions aren't showing up on the My Subscriptions page when the current user has no active subscription. So basically, there's no way for that user to signup for a new subscription. The initial signup & upgrade forms are working fine.

I also noticed that the Drop button doesn't actually remove the member's subscription. It's only removing their access level now. So on the member's My Subscription page, they still see that they are subscribed to the subscription that was just removed.

Any ideas on how to fix this?

  • Vinod Dalvi

    Hi @Christian,

    Thanks for posting on the forums.

    just updated to Membership 3.5.1.1 and I noticed that the subscriptions aren't showing up on the My Subscriptions page when the current user has no active subscription. So basically, there's no way for that user to signup for a new subscription. The initial signup & upgrade forms are working fine.

    The subscription page only displays current subscriptions where user can renew, cancel or upgrade his subscriptions.

    I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advise for us to know how a user can signup for a new subscription.

    I also noticed that the Drop button doesn't actually remove the member's subscription. It's only removing their access level now. So on the member's My Subscription page, they still see that they are subscribed to the subscription that was just removed

    .
    Do you mean dropping it from admin area?

    I tried dropping it from admin area and it worked fine.

    Please advise.

    Kind Regards,
    Vinod Dalvi

  • Christian

    Hello @Fabio Jun,

    I updated to Membership 3.5.1.2 and repaired the tables like you suggested, but I'm still seeing the same thing. Before version 3.5, I was able to see all of the available subscriptions when logged in as Admin with no current subscription. Now it's just blank.

    When a user is a registered member and has no active subscription, it redirects to the content protected page when trying to access the My Subscriptions page. Since this user is not a visitor and not a subscriber, there's no way to grant access to this page, is there?

    The only way that I was able to signup for a subscription was to visit the registration page and select the free membership. This redirected me to the welcome page because I was already registered. I have yet to test this process when selecting a paid subscription.

  • Fabio Jun

    Hello @Christian,

    I'm trying with no lucky to replicate this issue in my dev environment. Please let me know if your subscriptions page is correctly configured in Membership Options menu > Membership Pages > Subscription Page.

    Could you test subscribing a new member (not logged in) from the beginning?

    When visiting the subscription page as a Admin, it should not show the subscriptions as the Admin could not subscribe to any.

    Cheers,
    Fabio

  • Rheinard

    Hi @Christian,

    I'm a new developer on the Membership plugin and just checking to see if this problem still persists.

    Did you try the steps @Fabio suggested?

    Also, to make sure that users who are not visitors, but also have no subscription can see content, go to Membership->Options->General tab and select a default subscription for registered users. This can be the same as for visitors (stranger access level) and allow them to see the same as if they didn't have an account.

    Cheers,
    Rheinard

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.