not working with Doncha's plugin "domain mapping"

Having a domain mapping set on a site in a multisite installation, default domain set to something different than the multisite domain, and trying to require a password to get access does not work. It somehow redirects to a normal login page with url set to original multisite url.

  • Bruno

    Setup to test:
    1. Create a multisite installation.
    2. Install plugin domain mapping (either wpmudevs och Doncha's plugin from wordpress.org).
    3. Creat a new web aaa.multidomain.com
    4. install multisite Privacy and set it to require a password.
    5. Test site aaa.multidomain.com, should work fine.
    6. Change dns of domain fancydom.com to point to IP of multisite install
    7. Set domain mapping for web aaa.multidomain.com to fancydom.com
    8. Try to access site fancydom.com, no dice. Site redirects to standard loginscreen of site aaa.multidomain.com.

    Verification steps
    8 Set default domain mapping of site to aaa.multisite.com
    9 Try accessing site (with aaa.multisite.com or fancydom.com), both lands at correct password login and it works.

    So it plugin function password protection only works if default domain is set to original domain aaa.multisite.com. I have tried different setting both in domain mapping (both wpmudev and wordpress.orgs versions) and in multisite privacy.

    The only time the privacy plugin works, is when you set the default domain name of site to the original aaa.multisite.com hostname.

    I do have some other plugins activated but nothing that should interfere with this functionality. I do se that my webclient tries to access the correct url at fancydomain.com but is immediately redirected to the correct (privacy) URL of the aaa.multisite.com. Unfortunately it seems that the webserver the realises that the origin url domain is not default, so it immediately redirects to the normal (name/password) login of the aaa.multisite.com.

    Complete confusion ensues....
    Hope to get some help since I frequently need to set up sites with their own domains that should be password protected.
    Cheers!

  • Kimberly

    Hello there!

    What a situation we have here!

    Are you by any chance using nginx?

    Also, what are your settings for the Administration mapping? Is those settings what you are referring to when you say "Set default domain mapping" ?

    I'm not familiar with Doncha's plugin, very sorry. I do know that have a network option to map the administration area to the: original domain, mapped domain or domain entered by user.

    Best,

    Kimberly

  • Mason

    Hiya,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

  • Bruno

    No it is not resolved, but as a workaround for the time being, I use the domain mapping plugin found on wordpress.org site. I believe there is conflict between the wpmudev privacy plugin and the wpmudev domain mapping plugin. When I use the wordpress.org domain mapping plugin I do not experience the problem described in my first post.
    FYI I use a standard apache 2.2.22 and PHP 5.3.10 (with APC 3.1.7 opcode cache, really nice btw) on a ubuntu server 12.04.

    I saw a couple of misspellings (autocorrect is not always correct...) in my text. I will try to clarify test setup to recreate problem.

    Setup to test:
    1. Create a multisite installation (using multidomain.com).
    2. Install plugin domain mapping (either wpmudevs or Doncha's from wordpress.org).
    3. Create a new blog aaa.multidomain.com on multisite multidomain.com
    4. install wpmudev multisite Privacy plugin and set it to require a password.
    5. Test site aaa.multidomain.com, should work fine and ask for password
    6. Change dns of other domain fancydom.com to point to IP of multisite install
    7. Set domain mapping for blog aaa.multidomain.com to fancydom.com
    8. Try to access site fancydom.com, no dice. Site redirects to standard login screen of site aaa.multidomain.com and not the plugin privacy's password login screen

    This is not a big issue since the wordpress domain mapping plugin works, but I think you should have a look at the redirection logic of wpmu domain mapping plugin.
    There might be other plugins that could exhibit similar (to the privacy plugin) problems, although I have not noticed any other anomalies. I would like to use the wpmudev domain mapping plugin since it seems to be slightly faster (than the wordpress.orgs) and has the benefit to belong to the "family" of wpmudev plugins which I have always found to be of very high quality.

    I am therefore reopening this topic as not resolved. Besides it is alway good to squash bugs :slight_smile:
    Cheers and keep on coding!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.