Nothings happens on backup cron

Hi,

whenever I try to make a snapshot (run now or scheduled) just nothing happens.

I checked the cron jobs via WP Control, they are scheduled and executed. But just no backup happens, no logs are shown, no snapshot is created.

Settings:
WordPress Version 4.4.2
PHP Version 5.6.18
MySQL Version 5.1.73
Is Multisite No
WP_CRON Snapshot uses WP_CRON to run automated backups. If you have disabled WP_CRON via your wp-config.php you will not be able to schedule snapshots.
WP_CRON Enabled.
WP_CRON Lock timeout: 60
Folder Permissions Writable (0755) – /uploads/snapshots
Writable (0755) – /uploads/snapshots/_backup
Writable (0755) – /uploads/snapshots/_locks
Writable (0755) – /uploads/snapshots/_logs
Writable (0755) – /uploads/snapshots/_restore
OpenSSL The OpenSSL Apache module is require to make secure connections with destinations like Dropbox and Amazon AWS.
OpenSSL installed
cURL cURL is used when connecting to remote destinations like Dropbox and Amazon AWS.
cURL installed
Version: 7.26.0
SSL Version: OpenSSL/1.0.1e
Libz Version: 1.2.7
Protocols: dict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, pop3, pop3s, rtmp, rtsp, scp, sftp, smtp, smtps, telnet, tftp
PHP runtime information
Display Errors Off
Error Reporting 4983 - E_ERROR, E_WARNING
Magic Quotes Off
Max Execution Time (seconds) 120 The value displayed cannot be adjusted by Snapshot PHP scripts.
Memory Limit 64M - WP_MEMORY_LIMIT defined by WordPress wp-config.php.
256M - WP_MAX_MEMORY_LIMIT defined automatically by WordPress
Open Basedir /webspace/13/95262/berlinbritishschool.de:disappointed:webspace/13/95262/php_sessions:disappointed:webspace/13/95262/temp:disappointed:webspace/13/95262/php_includes:disappointed:mnt/webspace/13/95262/berlinbritishschool.de:disappointed:mnt/webspace/13/95262/php_sessions:disappointed:mnt/webspace/13/95262/temp:disappointed:mnt/webspace/13/95262/php_includes
Safe Mode Off
ZLib Compression Off

Thanks for your help!
Florian

  • Sajid

    Hi Florian,
    Hope you are doing good today :slight_smile:

    To make sure its not a bug in the plugin, I conducted a test backup using snapshot plugin on my own website ad it went well for me. So it means there is something wrong on your server or website.

    Run now and schedule later are basic sceduled and run in the background.

    Do you get any error message you got when you run the snapshot immediately or it runs safely ?

    Also, please scheduled a new snapshot by deactivating other plugins and installing the default theme (TwentyFifteen or TwentySixteen). This will ensure that there is no plugin or theme conflict.

    Now check if that works or not. If don't then open up the error log and share the error message (don't forget to mask the username and full path for security reasons) here that will help us understand why it is not backing up.

    Look forward towards your response :slight_smile:
    Cheers, Sajid

  • Sajid

    Hi Florian,
    Hope you are doing good today :slight_smile:

    You can find the server error_log file in the folder you have installed your WordPress website (see screenshot). You can find it via FTP program like FileZilla or via cPanel's FileManager.

    Alternatively you can also enable the WordPress specific error_log/debug_log by editing the wp-config.php file. Here is step by step guide to enable and find the WordPress specific debug.log file:
    https://easypiewp.com/wordpress-error-log-your-friend/

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:
    Cheers, Sajid

  • Florian

    Hi Sajid,

    thanks for your reply. I attached the error log.

    [27-Apr-2016 13:44:32 UTC] PHP Notice:  wpseo_pre_analysis_post_content filter/action is <strong>deprecated</strong> since version WPSEO 3.0! Use javascript instead. in /webspace/../wp-includes/functions.php on line 3573
    [27-Apr-2016 13:44:34 UTC] PHP Notice:  wpseo_pre_analysis_post_content filter/action is <strong>deprecated</strong> since version WPSEO 3.0! Use javascript instead. in /webspace/../wp-includes/functions.php on line 3573
    [27-Apr-2016 13:44:35 UTC] PHP Notice:  Trying to get property of non-object in /webspace/../wp-content/themes/../header.php on line 116
    [27-Apr-2016 13:44:36 UTC] PHP Notice:  Undefined variable: output in /webspace/../wp-content/themes/../inc/widget-templates.php on line 673

    Thanks!
    Florian

  • Sajid

    Hi Florian,
    Hope you are doing good today :slight_smile:

    Thanks for posting the error message here but those are not related to Snapshot cron and does not provide any kind of information regarding this issue.

    Please send in FTP and WordPress admin login details so I can troubleshot this issue further. You can send in these details via our private contact form in following format. During troubleshooting, I will be deactivating plugins/themes and also change some settings in snapshot. Yes, of course I will restore the site where it was afterwards.

    Subject: "Attn: Sajid Javed"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls
    
    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me 
    
    https://premium.wpmudev.org/contact/

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Sajid

    Hi Florian,
    Hope you are doing good today :slight_smile:

    Thanks for sending in the FTP and WordPress credentials. I tried to make a plugin and theme conflict test by deactivating the plugins and also switch theme to TwentySixteen (installed and deleted afterward) but it did not made any difference.

    Then, I tried enabling the alternate cron by adding following define in wp-config.php file, in some cases this can also be an issue that prevents running the scheduled backups but that did not worked either.
    define( 'ALTERNATE_WP_CRON', true );

    I saw following message on Add New snapshot screen, warning the server timeout is very low and that can't be increase by Snapshot plugin on run time to attempt to increase the time out in random cases if needed. I installed the plugin (deleted afterwards) to increase the time limit to 5 minutes that again made no difference at all.

    Your web server timeout is set very low, 120 seconds. Also, it appears this timeout cannot be adjusted via the Snapshot backup process. Attempting a snapshot backup could result in a partial backup of your tables.

    Finally, I tried to changed the Compression Library from PclZip to ZipArchive but that also did not worked.

    I created a couple of test Snapshots with 5 minutes interval for testing purpose (deleted all of those after testing) for all above steps.

    Here are things, I noticed and I think that can cause the issue.

    1. I saw you are using an older version of WordPress and most of the plugins are not updated. Please update the WP and plugins and then check again.

    2. Number one try to increase the maximum execution time from 2 minutes to 5 minutes.

    3. If its still does not work after upgrading the WP and other plugins then try disabling the WordPress cron and enable real cron instead.

    You can find a detailed articles on how to disable WordPress cron and replace with real cron.
    http://support.hostgator.com/articles/specialized-help/technical/wordpress/how-to-replace-wordpress-cron-with-a-real-cron-job
    https://www.siteground.com/tutorials/wordpress/setup-cron-job.htm

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:
    Cheers, Sajid

  • Florian

    Hi Sajid,

    thanks you so much for your help.

    I tried to update WordPress + Plugins. Unfortunately that didn't change anything.

    I also tried to increase the timeout, but our hosting provider doesn't allow timeouts above 120 sec.
    However, I was ensured that only 100% CPU usage counts as timeout time, which should not be the case here.

    Since we're using a hosting provider, we cannot setup a native cron job.

    Do you have any further idea?

    Thanks!
    Florian

  • Sajid

    Hi Florian,
    Hope you are doing good today :slight_smile:

    I am sorry for delay on this ticket. I heard back from the developer and he said that the only option we can try now (and left is) replacing the WP Cron with Real cron. He think this is the reason its not working properly.

    Could you please manage to replace the WP Cron with Real Cron ?

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.