"Notice:..."after new multisite install

On a new Multisite install (from scratch) everything went fine. I began installing plugins. CustomPress installed and activated without complaint. Then I installed and activated:
Communities
Prioritize Hooks
WordPress Chat
Not a good result.
I got the following 'love note' when I logged into the site: (But first, when I Deactivated the above, no more Notice.)

Notice: Undefined index: key in /home/chartsough/public_html/wp-content/plugins/communities/communities-framework.php on line 107 Notice: Undefined index: action in /home/chartsough/public_html/wp-content/plugins/communities/communities-framework.php on line 110 Notice: Undefined index: action in /home/chartsough/public_html/wp-content/plugins/communities/communities-framework.php on line 113 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/chartsough/public_html/wp-includes/functions.php on line 2722 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/chartsough/public_html/wp-includes/functions.php on line 2722 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/chartsough/public_html/wp-includes/functions.php on line 2722

Ah well. Now I should ___________________________
(fill in the blank)

Chris

  • aecnu
    • WP Unicorn

    Greetings Chris,

    Thank you for the great questions as always.

    Sorry to see that you are having issues with the Communities plugin but you have certainly come to the right place to get an answer.

    If I recall correctly and memory has not failed me are you not running a framework theme?

    If you are please let me know what happens when you change the theme temporarily to Twenty Eleven?

    Please advise.

    Cheers, Joe

  • Paul
    • The Green Incsub

    @Chris, Either you have enabled WP_DEBUG in your wp-config.php http://codex.wordpress.org/Editing_wp-config.php#Debug or your PHP installation is setup to report all manor of Warnings, Notices, Errors, etc.

    On a normal production system you don't want these displayed. All the information you provided are Notices. Theses technically are not considered Errors by PHP. A Notices really is informational.

    For example to first Notice -

    Notice: Undefined index: key in /home/chartsough/public_html/wp-content/plugins/communities/communities-framework.php on line 107

    This is telling you some index named 'key' was not initialized before being used. Does this prevent your site from loading properly? Probably not.

    Still these Notices should be taken care of. I know the Communities plugin is somewhat old. I inherited it from a previous developer. Was not aware it had these issues. For now if you turn off WP_DEBUG you should not further see these Notices.

  • Chris
    • Design Lord, Child of Thor

    Hi Joe,
    I am running Twenty Eleven. I don't plan to stay there, but you have to start somewhere.

    Hi Paul,
    I will check on debug mode. Is that the default on a new install?

    I will ping my ISP (also the Guru of my system) and ask him to check on PHP.

    Chris

  • Paul
    • The Green Incsub

    @Chris,

    So you are no longer seeing the Notices???

    The wp-config.php sites in your site root (or sometimes not) and contains your database connection login/password and some other directives like WP_DEBUG. Think of it as a global configuration file used by WordPress.

    Or if you prefer not to read the above paragraph. Ignorance is bliss. As they say.

    If this is now solved. Please mark as resolved. Thanks.

  • Paul
    • The Green Incsub

    @Chris,

    I just noticed what you might be asking. I just noticed the '~' on the filename. So I'm assuming you see a normal 'wp-config.php' and a second file 'wp-config.php~'. The file with the '~' is a backup copy. Some UNIX command line editors like Emacs will create a lock/backup of the file edited and append the '~' to the end. This is somewhat of an annoyance since if you edit many files within the folder you will see bunches of these.

    This can be controlled. check this Stack Overflow thread.
    http://stackoverflow.com/questions/151945/how-do-i-control-how-emacs-makes-backup-files

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.