Oh What have I done this time...

Ok, I installed multi-db, and when I did that, I got this error:
Warning: mysql_free_result() expects parameter 1 to be resource, string given in /home/mysite/public_html/wp-content/scripts/move-blogs.php on line 140

then, when I refreshed the screen, the warnings went away. But then in my dashboard, I now have this warning:

Warning: mysql_set_charset() expects parameter 2 to be resource, boolean given in /home/mysite/public_html/wp-includes/wp-db.php on line 554

What did I do wrong?