On GZip section of hummingbird, got the warning "Your

On GZip section of hummingbird, got the warning "Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)..." but i told my host and told me that the mod_deflate module is enabled on the server, and i am not using other plugins for optimization that may conflict with the hummingbird.

The same issue is with the mod_expires on "Browsing Caching" section.

Please help.

    Adam Czajczyk

    Hello Kyriakos,

    I hope you're well today and thank you for your question!

    The message suggests that the "mod_deflate" module may not be enabled but that may not always be the case. Please double-check your server for following issues as well:

    - check if there's a Varnish cache running on server (or any other server-side caching solution); if it is, make sure to purge/empty its caches

    - make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":

    zlib.output_compression = On

    In case it's set to "off" you will want to change it to "on" and restart Apache

    - there's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    Unfortunately, you may want to contact your hosting provider again for help with this but I hope it should fix the issue.

    The same issue is with the mod_expires on "Browsing Caching" section.

    I assume that your host also confirmed that it's enabled? I think it would be also good to find out (from them) what configuration they use for it - is it a default Apache configuration or did they set their own rules?

    Let me know please what they said about that all!

    Best regard,
    Adam

    MindSeed

    Hello Adam Czajczyk,

    A bit late but i didn't find the time to post earlier. The host's answers regarding the issue are:
    -------------
    Varnish is not running on the server. We can rule this out.
    You can enable zlib.output_compression by selecting a PHP version in cPanel (under Select PHP Version > Switch to PHP Options).

    The default MIME types are the following:
    image/*=A604800, text/css=A604800, application/x-javascript=A604800, application/javascript=A604800

    The types "text/html" and "text/javascript" aren't included because it would overload the server by having them included server-wide. You can enable them by adding these rules to your .htaccess file:
    ExpiresActive On
    ExpiresByType text/html "access plus 1 day"
    ExpiresByType text/javascript "access plus 1 years"

    Please note that we don't run Apache on our servers. We run only LiteSpeed Web Server, which is a commercial drop-in replacement for Apache.
    ----------
    So i am going to do what he said and i'll be back

    MindSeed

    Hi again,

    After enabling the "zlib.output_compression" issues with compression are now solved. Unfortunately even after adding in .htaccess the following lines:
    ExpiresActive On
    ExpiresByType text/html "access plus 1 day"
    ExpiresByType text/javascript "access plus 1 years"

    On Browsing Cache Summary the "javascript" "css" and "images" are changed to the recommended values from dropdown but are not change from "7 days" to "8 days" after "re-check expiry". The media working fine (8 days).

    Adam Czajczyk

    Hello Kyriakos,

    Thank you for getting back to me with this information.

    I'm glad that your host gave you such a handy answer. There's also a very useful information on the server. The LiteSpeed web server is indeed a replacement for Apache and by the design should be fully compatible with it (though much faster and more lightweight), yet it still doesn't cover full set of Apache features and configuration options.

    As it turned out, although it's still less popular than Apache, IIS and nginx, more and more hosting providers are using it and our developers will most likely include full support for it with one of future Hummingbird version but for the time being it should be treated as Apache and some slight "glitches" may occur.

    Also, your host mentioned that "text/html" and "text/javascript" MIME types are not included by default. What the suggested was in fact "hard setting" cache for this.

    Taking both these facts into account, I think you should be good to go now even despite the fact Hummingbird doesn't let you change from 7 to 8 days values. The compression should now be working fine. Just to make sure I've checked that and both Pingdom Tools and checkgzipcompression.com testers confirm that and the WhatsMyIP tester suggested earlier in this thread by Cameron confirms compression to showing over 75% compression savings level

    Best regards,
    Adam