One domain requires removing privacy and re-adding to see site.

For the plugin Sitewide Privacy Options, one one of my sites, if I have it set to one of the three:

I would like only logged in users to see my blog.
I would like only logged in users who are registered subscribers to see my blog.
I would like only administrators of this blog, and network to see my blog.

Then it does not let anyone view the content, even when logged in, even the super admin, until I reset it back to one of either:

Allow search engines to index this site.
Ask search engines not to index this site.

And then view the site with that specific user, then set it back to one of the three more secure options and I can view just fine.

Any thoughts?

Kind Regards

  • aoirthoir

    "it's just that one site that does it, and not other sites?"

    I retested, it seems to be all sites that we are using the WordPress MU Domain Mapping on. It does not give us the problem if we are not mapping.

    "What is the message it gives when viewing the site in that case?"

    It just reroutes me to the login, there is no message.

    "Have you checked that there's not some odd conflict with other plugins on that site? Perhaps you could try deactivating plugins on that site to see?"

    I deactivated all site plugins. I deactivated all network plugins except for:

    Sitewide Privacy Options for WordPress Multisite

    WordPress MU Domain Mapping

    I reset the theme to twenty-ten.

  • aoirthoir

    I think we can mark this solved. Since the entire point of the privacy settings is to keep people out of the site except those that are logged in, the domain itself just does not matter that much. After all they have already signed in via the network domain right?

    So I set the Domain Mapping plugin to use the subdomain.host.tld as the primary domain and the full domain (subdomain.tld) as just another on it. So for instance helloworld.com forward to helloworld.mynetwork.com. And in this case the privacy setting works.

    I am going to mark as Resolved just because that's a reasonable solution to me.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.