One provider for multiple services at the same time

Hello.

We have one provider and 4 services.
If we book one of services, for example, 12:00-13:00 - we can see that 3 other services also shown as booked.

But we need following configuration:
one provider can provide 4 different service at the same time to 4 different client.
1 client per service, not more.

How can we configure that?

  • Michael Bissett

    Hey @denis, hope you're doing well today! :slight_smile:

    If we book one of services, for example, 12:00-13:00 - we can see that 3 other services also shown as booked.

    That would be because a provider is treated as a single person, he can only be in one place, performing a single service, at one time.

    Seeing as you're scheduling quest rooms on your site, the alternative would be to set up 4 separate service providers (as dummy providers), and have them all offer a meeting room service.

    You could lay out the code for the appointment scheduler like this:

    <table>
    <tbody>
    <tr>
    <td colspan="2">[app_my_appointments]</td>
    </tr>
    <tr>
    <td>[app_service_providers]</td>
    </tr>
    <tr>
    <td colspan="2">[app_monthly_schedule]</td>
    </tr>
    <tr>
    <td colspan="2">[app_pagination month="1"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_login]</td>
    </tr>
    <tr>
    <td colspan="2">[app_confirmation]</td>
    </tr>
    <tr>
    <td colspan="2">[app_paypal]</td>
    </tr>
    </tbody>
    </table>

    As that would hide the service dropdown on the page. :slight_smile:

    And if you're wanting to hide the service name on the confirmation page, you can add this CSS code in via a plugin like Simple Custom CSS:

    .appointments-confirmation-service {
    display: none;
    }

    If you're wanting to change the language for "Service Provider" on your site to say something like "Quest Room", you could try using a plugin like this to translate that:

    https://wordpress.org/plugins/codestyling-localization/

    How's that for a start? :slight_smile:

    Please advise,
    Michael

  • Michael Bissett

    Hi @denis,

    Actually, if you set things up the way I mentioned, there's some extra steps you can take to get around that issue:

    1. When creating each of the dummy users, set the relevant room name as the Nickname of each user (the username can be a generic name if you wish).

    2. Go to Appointments -> Settings -> Add-ons, and enable the "Service provider names" add-on. This is what we'll need to change the name of the service provider that gets displayed to your visitors. :slight_smile:

    3. Once that add-on is enabled, go to Appointments -> Settings -> General, and at the bottom of the page you'll see the "Worker display names" section. You'll want to set the "Default" option to "Nickname", that'll change the name of the service provider that gets displayed.

    Once you've done all that, you should be all set! :slight_smile:

    Let me know if I can be of further assistance here please!

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.