no access to pages

one simple membership is set up.
i added a user manually (user list was not detecting user even when username was fully typed out).
the user shows as "active".
i only added a couple BuddyPress pages to test and they cannot be accessed by the user or site administrator.
site admin is having same no access problems and cannot be added as a member in backend.
on the "memberships" menu there is an "active" switch which is on.
on the "overview" page there is another "active" switch which is on.
jumping to the "edit page access" there are also more "active" switches for each page there.
on the "settings" menu there is another "active" switch which is on.
i guess the developer really loves these switches,
wish i could say the same.
back to "memberships" menu under "payment options" i choose "free"

trying everything under the sun,
i switched off the lovely "active" switch under "Memberships"/"overview" for one page,
still no access.
saw it was still showing under "Protected content" menu so removed it there,
still no access.
added them back and i really do not know what to try next or how to make sense of this plugin.

nothing seems to work how i believe it should and there is a lot of confusing back and forth with the menus.
everything seems very unintuitive to me.

what may i be doing wrong ?

  • Tyler Postle

    Hey Randall,

    Hope you had a great Christmas and/or Holidays

    Are you using the latest version of Protected Content? The latest version is 1.0.4.7 and some important bug fixes have been included in the last couple versions.

    So even when you have those pages as inactive for their protection, your users still can't access them?

    The reason there is the access toggle for each page is so you can manage the page protection between all your memberships you might want a page to be protected for 1 membership but not with the other.

    Look forward to hearing back Randall!

    All the best,
    Tyler

    PS. If you're still having issues, would you mind granting support access? You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

  • amused

    1.0.4.7 yes
    as far as i know support access does not work for local sites ? (bitnami app)
    still granted access just in case.

    only 1 simple membership as mentioned.
    was wondering if i even need to create a membership level and simply add protected pages and logged in users will have access, but i tried that and still no access.
    do not need any complicated paid membership,
    just to block pages for people who are not registered wp site members.
    "So even when you have those pages as inactive for their protection, your users still can't access them?"
    don't know what u mean by having those pages inactive.
    u mean with the "green" active switch on ?
    as i mentioned above, those lovely green switches are on.
    turned then off as well no access.

  • Tyler Postle

    Hey Randall,

    Hope you're doing well today!

    Ah yes, support access doesn't work on localhost sites - my apologies I didn't realize it was the localhost one you were working on.

    Protected pages should always be protected from visitors no matter what, whether they are selected for a specific membership or not; however, if you want logged in users to access those pages then yes you need to create a simple membership level and have users sign up for that when they register

    don't know what u mean by having those pages inactive.
    u mean with the "green" active switch on ?

    Sorry, yes I meant the green toggle being off. If it's off(grey) then visitors should be able to visit those pages. Toggle it back to green then they will be protected again.

    Site Admin's will always be able to see all content so make sure you test with a logged out user.

    So, with all that said. Is there anything that is not working?

    Look forward to hearing back Randall!

    All the best,
    Tyler