Ongoing SmartCrawl JS Errors

SmartCrawl is generating a myriad of JS errors. These are preventing other plugins from functioning properly.

It also seems to suggest that SmartCrawl itself is having issues. Particularly around OpenGraph functionality.

It appears there are multiple tickets open on this topic and that they have been pending for several weeks. I sure hope you have a resolution soon as this is a major problem for our clients.

Example 1 on a standard post:

Uncaught TypeError: editor.on(…:wink:.trigger is not a function

at wds-metabox.js:3

Example 2 on a custom post types. (Multiple plugins):

wds-admin-opengraph.js?ver=2.0:1 Uncaught TypeError: Cannot read property ‘frames’ of undefined

at init (wds-admin-opengraph.js?ver=2.0:1)

at new window.Wds.OgImage (wds-admin-opengraph.js?ver=2.0:2)

at HTMLTableCellElement.<anonymous> (wds-admin-opengraph.js?ver=2.0:2)

at Function.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,underscore,jquery-ui-core,jquery-ui-wi…:2)

at a.fn.init.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,underscore,jquery-ui-core,jquery-ui-wi…:2)

at HTMLDocument.init (wds-admin-opengraph.js?ver=2.0:2)

at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,underscore,jquery-ui-core,jquery-ui-wi…:2)

at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,underscore,jquery-ui-core,jquery-ui-wi…:2)

at Function.ready (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,underscore,jquery-ui-core,jquery-ui-wi…:2)

at HTMLDocument.K (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,underscore,jquery-ui-core,jquery-ui-wi…:2)

  • johnol
    • Site Builder, Child of Zeus

    Every time I’ve tried to “piggyback” on top of someone else’s report of an issue, I’m told to open a separate ticket… so simply behaving as previously instructed. Has that policy changed?

    Likewise, there’s no “official” release from WPMUDEV that this has been acknowledged as a bug… simply that they replicated it with a singular plugin and that developers have been notified…

    Furthermore, there haven’t been any updates to that ticket since 3/28 which is a LIFETIME when you have hundreds of broken client sites because Smart Crawl is being dumb… which is the case we are in.

    Meanwhile we’ve lost PRECIOUS time trying to troubleshoot.

    One additional suggestion for WPMUDEV is they should give some sort of status indicator on each plugin. Green = zero reported issues or known conflicts. Yellow = some users reporting problems. Red = known issue that’s being resolved.

    This way, at a glance, we could identify what WPMUDEV products might be getting in the way of our systems working.

    At the very least WPMUDEV should give an update on the progress rather than letting the ticket sit for days…

  • Patrick
    • Support Monkey

    Hi again johnol

    I will certainly make every effort to get this issue brought higher up the queue and in front of the developers.

    And yeah, piggybacking on someone else’s ticket as you say is still kinda frowned upon, as that needlessly sends email notifications to the topic started who might not care to receive them.

    However, following a thread is perfectly fine. That way, you get an email notification of new replies on threads that interest you. :slight_smile:

    And I do like the status indicator idea. I recall we had discussed internally having something like that a couple of years ago. It may worth revisiting.

  • johnol
    • Site Builder, Child of Zeus

    Thanks Patrick.

    I don’t mind following a ticket if it appears it has activity. In this case the ticket had gone for some time without an update. This is urgent. What we consider to be a critical part of SEO is BLOCKING other systems from working. Makes us look dumb in front of hundreds of clients…

    From a client: “Why are you insisting on us using this plugin that we’ve never heard of when virtually everyone else recommends YOAST or All In One SEO???”

    From another client: “This is the busiest time of year for us… you guys claim to be reliable… you claim to manage our software for us so we don’t run into these sorts of problems…”

    So, when I see a ticket that appears to be ignored and I have clients complaining and still more sites that are broken, I have to act.

    (We are paying you guys a PREMIUM for the best, most well maintained set of multisite plugins in the industry… I expect better than ignoring a ticket for days without so much as a feedback ping.)

    And given your stated policy of not liking piggy backing, the ONLY choice is to submit a duplicate ticket. Hopefully it draws attention and underscores the urgency of obtaining a resolution.

    Don’t like piggy backing? Don’t like having multiple tickets with the same topic? Merge them. If two (or more) tickets complain of what is found to be the same issue, then administratively merging the tickets is the only path forward given your stated support preferences…

    And I say this with a ton of respect… Please don’t chide a client for doing what you folks have stated you prefer us to do. It sends mixed messages and doesn’t really help calm nerves. Don’t want multiple tickets on the same topic and want us to “follow” tickets instead? Do a better job of communicating with the ticket submitter so they (and everyone else searching for an answer) can see the issue is being properly dealt with in a timely manner…

  • johnol
    • Site Builder, Child of Zeus

    So 4 days without a response on this ticket and the other ticket you referred to and said I should follow hasn’t been updated since Mar 28.

    I have to say this is pretty lackluster support and I’m deeply disappointed…

  • Birdcho
    • WPMU DEV Initiate

    hi, I had to deactivate smartcrawlr as it wasn’t working as expected and interfering with other plugins that used to work normally…

    my developer said: “SmartCrawl is giving a jQuery error that is messing with your shipments plugin”

    there’s also another support ticket open for quite a few days now that explains an error with woocommerce.

    https://premium.wpmudev.org/forums/topic/conflict-between-woocommerce-and-smartcrawl-renames-shop-page-title

  • johnol
    • Site Builder, Child of Zeus

    Yes. I opened this ticket to demonstrate the issues went beyond just woocommerce… didn’t want WPMUDEV developers ONLY thinking the conflict was with one plugin… it’s with many…

    Also, WPMUDEV has been sending mixed messages about opening individual tickets for issues vs. piggy-backing on other already open issues…

  • Paul
    • The Incredible Plugin Injector

    2 weeks later and still no response? I have all my websites that use SmartCrawl that are having js errors, preventing the Dropdowns in TinyMCE not to work (that’s all I noticed so far)… Do I need to uninstall SmartCrawl and install All in one SEO (a highly recommended plugin in the community)?

    Or is someone from WPMUDev going to resolve this issue ASAP?

  • Adam Czajczyk
    • Support Gorilla

    Hello Paul,

    Does this happen with any specific theme or some TinyMCE related add-on plugins?

    I’m asking because I was trying to replicate that on my test setup with basic Twenty Sixteen theme and a standard WP (TinyMCE) editor but it works fine for me with the most recent SmartCrawl release.

    Just to be clear, I’m not saying that there’s no issue, just trying to find a way to replicate this so we could investigate it further/again. I hope that makes sense so any additional information that you might provide would be helpful.

    Kind regards,

    Adam

  • Predrag Dubajic
    • Support

    Hi Paul,

    After couple of more tests I was finally able to replicate this issue, it seems to be specific to multisite installation but I’m still not sure why exactly as it happened only on one of test sites I used.

    I have gathered all the info from my tests and forwarded it to our developers so hopefully that will help them to debug this further.

    Best regards,

    Predrag

  • Paul
    • The Incredible Plugin Injector

    I saw it on a single site installation. Now I am working on my own site, and do not see the issue… I’m glad you forwarded this to the dev team and hopefully a fix would roll out and fix the sites that are affected. I really don’t have time to check which ones are affected, but I took note of the one affected.

    Best regards,

    Paul

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.