Only one way sync possible Appointments+

I installed the A+ plugin to my Wordpress website.
When I'm testing the plugin it only sync's in one way (Webstite -> Gcal). If I book an appointment in Gcal, the timeblok stays available on the website.

I've the settings for the (only) service provider on full sync (A+ <> Gcal) in the "Google Calendar settings tab"... What can be the problem? Thanks in advance!

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Pieter

    Hope you are doing good today :slight_smile:

    Some times its take time to reflect changes made on google calendar on your website.

    When you booked an appointment on google calendar ? Let me know if its did come through after a sufficient time.

    Also enable support staff access from WPMUDEV > Support > Support Access > Grant Access or see below manual for more details on how to enable access.
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Pieter

    Hope you are doing good today :slight_smile:

    Appointments + totally depends upon Google in this case to receive response from calendar. As soon as it receive response from Google Calendar it updates the appointments and booked it in A+ calendar.

    If you made an appointment and want to effect immediately then you can force import it from Appointments > Settings > Google Calendar > Integration Mode > Import and Update Events from GCal Now. This will immediately sync and update appointments if any.

    Hope that helps :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.