Only the last entry gets indexed

I have WP 3.8.1 running with Global Site Search (and Post Indexer) installed. Within Post Indexer I have "Post" and "Page" as types of posts to index. I did a Rebuild and everything showed up beautifully and was all "findable" in a search. Then when I added or updated a post or page only the last pages/posts updated are found in a search -- I do not mean the Stats, I mean the search results. I would then do another Rebuild on the Indexer plugin and the same thing. Everything shows up in as available for searching and as soon as there is any update on any Blog site only the new or updated page/post is searchable.

  • Patrick

    Hi again @scottlowe

    I just now got back to this. It's an odd one.

    After updating the "Hello World" post on a sub-site, I rebuilt the index at the network level. Then did a search for "hello world" on the Site Search page here:

    Even after updating the post again after the rebuild, every single instance of "hello world" appears in the search results.

    I know this is a tedious question but, have you tested with all other plugins deactivated? And with a default theme?

  • Scott Lowe info. I did actaully deactivate all the plugins before I started this thread. Good to ask though. However, here's something I did not see before.

    I did another rebuild and searched for "2012" which appears all over the site in pages and post. I got many results. I looked at a couple of the pages with another browser trying to figure things out and then did the exact same search and got three. One more time and got nothing. The statistics page did the same. It showed a lot of info then just one page one the Home site. The index seems to have a leak.

    An other thing I noticed is when I went to Network Settings > Site Search the List Post Types had (1) All and (2) Page as choices. Not Posts. Just now I looked and see it says (1) All and (2) Posts but not Pages.

    One last thing. I installed the Search plugin first followed by the Indexer plugin. Could that be a problem?

  • Scott Lowe

    I got it to work but I am not certain which steps fixed it. I will just log the steps anyway to complete this thread.

    * I uninstalled the Global Search and Indexer plugins, in that order.

    * I did not install Dashboard (which had not been done before)

    * I installed the Indexer first (last time I installed Global Search first) followed by the Search.

    * I did a Reindex but the problem continued.

    * Under Indexer > Global Settings I changed the Default Post Types order from post then page to page followed by post.

    (I also set the "Remove indexed post older than" setting to 20 Years. I did not expect this to matter but I did it anyway)

    The first thing I noticed is that was fixed was the pull-down under
    Network Settings > Site Search > List Post Types.
    Before it would either show All and Post or All and Page. It now shows All, Page and Post.

    I Reindexed and everything works fine now.

    None of this makes a lot of sense. However, if I were to guess it was the combination having installed the Search plugin before the Indexer and having the Default Post Types being post-page rather than page-post.

    Hope this is useful to someone.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.