Optimizing images doesn't seem to be working

Hi, I have been looking at Pagespeed Insights the past week. Yesterday I had the score of something like 67 for mobile and 83 for desktop. I went back on it today and now I'm getting 67 for mobile but 34 for desktop... I don't understand why my desktop has suddenly dropped. So I downloaded the new optimized images it provided and uploaded them via FTP but I'm still getting the error. I double checked that all my images are smushed with WP Smush Pro and it seems to be all done. The images that it recommends I optimize are the ones in the slideshow on the top of my homepage and a couple of the thumbnails of the blog post links available (which I can't change as it will then affect the look of the thumbnails of those posts in the main blog page). Any advice at all please? Website here. Thanks.

  • Sajid

    Hello Clare,
    Hope you are doing good today :slight_smile:

    I see there are still few images that google suggesting to compress and resize. Please try to super smush the images and then check again.

    Also, make sure you select Include Original Images option to smush full size of images too since you are not using thumbnails for slider.

    Also, please enable support staff access so I could take a closer look. To grant access go to Dashboard -> WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

    • Clare

      Hi Sajid, that's odd, I'm sure I replied to you but it doesn't seem to have appeared here...

      Anyway, I did have the include original images option enabled. I do seem to have roughly 128 images that do not want to be smushed. But I am wondering if this is because since I installed the plugin, I have had a SSL certificate installed, so not sure if that's messing something up there? I have granted access for support if you want to have a quick look to see.

      But I checked Pagespeed Insights again today, and I seem to be back at 67 for mobile and 89 for desktop. No idea what has happened to change that again!

  • Sajid

    Hello Clare,
    Hope you are doing good today :slight_smile:

    Thanks for enabling support staff access again. I could see that all those images are of slider/banner. The only thing I can think of at the moment is that may be this slider loads slide images into a container with smaller viewport and then load those images into slider later.

    Since it is first loading bigger images in smaller container on load so google pagespeed assumed these are meant to be used here instead of big banner.

    Could you please try using a different slider like free plugin Meta Slider or any pro alternative like Revolution slider plugins instead ?

    Do not replace it with home page right away. Instead create another page and use the slider there with same images and check the google page speed results and compare wth home page one.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.