"Our Projects" page does not show up, even though it is listed in menu

I have published the "Our Projects" page and have it in the menu. When I am logged in as the admin, I can see the menu option at the top of the page; however, if I go to our website without being logged in, the "Our Projects" menu hyperlink is not there. If I use the search function and search "Projects Page" I can get there. I cannot figure out why it is not showing up as a menu option when I have published the page and added it to our menu

  • Kris
    • Support

    Hi Kara

    Hope you are doing good today.

    There could be many reasons of this:
    1. cache issue (please clear your site and browser cache or try in other browser)
    2. additional plugin: there is possibility that you use some sort of plugin to hide menu item for not logged in users

    I'm not logged user on your site and I'm able to see this item (Our Projects) in menu and also able to enter this page.

    This page also exist in search results
    Please confirm do you see this also on your side after you clear you browser and site cache.

    Kind Regards,
    Kris

  • Kara
    • WPMU DEV Initiate

    Good morning -

    I have cleared browser cache. I have tried to pull up our website on my mobile device, in Google Chrome and Internet Explorer. Some of my collegues have done the same and we are still not seeing the Projects page in the menu section.

    Also, when I get to the projects page whether it's through the search tool or when I am logged in as the admin, the page doesn't fully load all of the project pages I have created. It loads 6. Then if I scroll up and then scroll back down, it loads the remaining projects.

  • Kara
    • WPMU DEV Initiate

    Good morning Kris -

    Some how the Projects Page showing up in the menu has corrected itself. So weird.

    Anyway, the page is still only loading with 6 projects when I have at least 12. I will go ahead and provide access.

    Thank you so much for all of your help.

    Regards,
    Kara

  • Kara
    • WPMU DEV Initiate

    I just cleared the cache. I am noticing the projects are extremely slow to load. The first 6 seem instant while the remainder takes about 15 seconds. I also tried this on my cell phone.

    Is there something I can do to improve the speed?

    Thank you so much for all of your help.

    Kara

  • Nithin
    • Support Wizard

    Hi Kara,

    The first 6 seem instant while the remainder takes about 15 seconds. I also tried this on my cell phone. Is there something I can do to improve the speed?

    I wasn't able to replicate a lag of 15 seconds, the projects seems to load within 4-5 seconds when tested, which seems to be how the plugins behaves.

    Maybe you could try excluding the /our-projects from getting cached, so that you could avoid getting anomalies regarding this? You could exclude the projects page by adding /our-projects in a new line, under Hummingbird Pro > Caching > Exclusions

    Please check whether that makes any difference, and advise if I'm missing anything. hope this helps. Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

  • Kara
    • WPMU DEV Initiate

    Good morning Nithin -

    Thank you for the recommendation to exclude the projects page from getting cached. That worked! I really appreciate all of your help as I am not a Web Designer/Developer, but need to manage this site so I am learning as I go.

    Have a wonderful day.

    Regards,
    Kara

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.