Padding doesn't appear to be working

Hi,

We are tesing appointments+ here:

http://www.aspiringsolicitors.co.uk/beta and when I check 'Padding' either on the 'Service Worker' or on the 'Service' itself it doesn't add a 'time space' between one time slot and another, but actually adds time to the 'Time base (minutes)'

So we have 15 minutes and if I add 5 minutes of Padding, I get 20 minutes in calendar.

Can you help?

  • Kasia Swiderska
    • Support nomad

    Hello Chris,

    In Appointments+ by default the padding time is added before and after an appointment, and they are hence listed with padding time include.
    I tested this on my site and it works correctly - could you explain more on how do you think it should be working? Or describe what do you want to achieve so I could see if there is better solution than using paddings

    kind regards,
    Kasia

  • Chris White
    • Design Lord, Child of Thor

    Hi,

    I am sure before the update the 'padding time' was added before or after a timeslot. So if we set working hours to

    2pm to 3pm for 15 minute timeslots. with 5 minutes padding before next timeslot.

    So in an example, the first timeslot available would be

    2pm - 2.15pm
    Then the next timeslot would be, after 5 minutes padding.

    2.20pm - 2.35pm

    Then padding 5 minutes next timeslot would be

    2.40pm - 2.55pm

    THis what we had prior to update, now we have this, using the same example;

    2pm to 3pm for 15 minute timeslots. with 5 minutes padding before next timeslot.

    So in an example, the first timeslot available would be

    2pm - 2.15pm - is showing as 2pm - 2.20pm

    The next timeslot is showing as 2.20pm - 2.35pm

    The next timeslot is showing as 2.35pm - 2.50pm

    So the 5 minutes padding has been included in the timeslot available. Which isn't 'padding' it is jsut extending the 15 minute timeslots we want to make available.

  • Nithin
    • Support Wizard

    Hey Chris White,

    Hope you are doing good today. :slight_smile:

    I tested the padding in my system, and it does seems to work fine, with correct padding times, so this seems to be a site specific issue, to have a better idea regarding this, could you please enable support access, so that we could give a closer look, and see what's being missed here.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Chris White
    • Design Lord, Child of Thor

    hi,

    We don't use your plugin management plugin. As the site has too many plugins already and we are developing some custom functionality.

    if you let me know where i can post the username and password I can give you access.

    cheers
    Chris

  • Kasia Swiderska
    • Support nomad

    Hello Chris,

    I case you don't want to use WPMU DEV plugin could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password) (this is in case we have to turn debug mode)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hey Chris White,

    Hope you are doing good today. :slight_smile:

    I'm afraid, I'm not able to login using your WordPress Dashboard credentials, that you have sent. I even asked one of my colleage, to check whether the WP login works, but it doesn't work for us. Please check the credentials, and re-send the WordPress Dashboard login credentials as you have done before, so that we could give a closer look. FTP is working fine though.

    Please let us know once you have corrected this, have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Rupok
    • Support Ninja

    Hi Chris,

    Thanks for sending updated credentials. I tried to login with the new creds but it's showing me the following error after entering your new credentials:

    Can you please let us know when we can access your dashboard to investigate this issue? I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska
    • Support nomad

    Hello Chris,

    Could you update Appointments+ to latest version? Or I can do that, but please confirm that you have created backup of your site.
    It is always best to check things on the latest version of plugin - it might be that issue you have was only specific for some sites and that is why we were not able to replicate, but new version might already address it.

    kind regards,
    Kasia

  • Rupok
    • Support Ninja

    Hi Chris White,

    So sorry for the inconveniences and thanks for sending all these details. I could regenerate this on my test site. So I'm pinging our developer regarding if this is expected behavior or a bug. I believe, he will come up with his valuable opinion on this very soon. We will update you as soon as we get anything from him.

    Please keep in mind, our developers work around the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide a feedback. I will appreciate your patience.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi Chris White,

    I'm confirming you that our developer is actively working on this issue. As you said "I am sure before the update the 'padding time' was added before or after a timeslot", can you please tell us on which version of Appointments+ the padding time was added before or after a timeslot? That will facilitate the troubleshooting process.

    Our developer requested for this information. I'll forward this to our developer as soon as you confirm.

    Have a nice day. Cheers!
    Rupok

  • Chris White
    • Design Lord, Child of Thor

    Hi ,

    Sorry for the delay we were using Padding time in the pro version of the plugin. As we were told that Padding does not exist in Appointments Lite.

    Also there is an issue with with time display in back end. When an appointment is booked for example 11am it shows in booking area of the back admin as 'midnight' this is for all bookings.

    many thanks

  • Ivan
    • Developer

    Hello Chris White !

    Current version of Appointments+ PRO is 2.0.5 now. What version of Appointments+ PRO did you use when the update the 'padding time' was added before or after a timeslot?

    I tested the issue with time display on my site and I see the same time. Could you please enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Ivan.

  • Ivan
    • Developer

    Hello Chris White !

    As I have said previously we do not want to install your app.

    It seems I missed this information, I'm sorry.

    Also there is an issue with with time display in back end. When an appointment is booked for example 11am it shows in booking area of the back admin as 'midnight' this is for all bookings.

    Are you saying that with the latest update the issue is solved?

    I tested this issue using Appointments+ PRO (version 2.0.5) on my sandbox site and it's work fine. Without Grant access I can't tell you more information why you have this issue.

    Could you provide information which version of Appointments+ PRO did you use when the 'padding time' worked as you want?

    Best regards,
    Ivan.

  • Chris White
    • Design Lord, Child of Thor

    Sorry I can but I seem to be having to supply the same information over and over again.

    The version I am currently using is 2.0.4 which I updated at the behest of your developers, because I didn't have the latest version. And I can confirm the issues remain in place.

    When I first submitted this issue on Feb 21st I provide access to the back end of the website.

    So now I shall update the plugin again and let you know if this latest update removes issues.

    Many thanks

  • Ivan
    • Developer

    Hello Chris White !
    If I correct understood you, you have 2 issue:
    1. The 'padding time' works wrong.
    2. The time in back end shows wrong.

    Regarding the first issue - Currently, you are using is 2.0.4. And which version did you use before? (when the 'padding time' worked as you want) It needs that our developer can compare these versions and found what it was changed.

    Regarding the second issue - Without Grant access, I can recommend you try to update Snapshot plugin and if the updating won't help, you can do a plugin conflict test using this troubleshooting flowchart.
    https://dl.dropboxusercontent.com/u/65475634/WPMU/Support-Process-Support-Process.gif
    If I incorrect understood you, please, feel free to correct me.

    Best regards,
    Ivan.

  • Chris White
    • Design Lord, Child of Thor

    Hi

    Sorry for the delay

    1) I cannot remember the plugin version but on our live site it is Version 1.9.4 and that has the two issues.

    2) I think with this version the 'time' issue appears to have been fixed. As I have just made a test booking and the times are all correct.

    3) The padding issue remains.

    With these settings: https://screencast.com/t/PhZkQtJy5w

    The padding issue still remains and it doesn't matter if I adjust Padding in

    a) Services or
    b) Service provider's area

    The 15 minute mettings is extended to 30 minutes

    see here: https://screencast.com/t/l2TfdirjjWun

    I can and have granted access previously what email address do I send the access to?

    Many thanks

  • Kasia Swiderska
    • Support nomad

    Hello Chris,

    We are checking this issue - so far we tested 1.9.4, 1.8 and 1.5.4 version of the Appointments and in each of those adding padding makes free slot longer. I'm waiting for feedback from our Appointments+ expert when that change might be applied. As soon when we will know more we will update thread.
    Just in case, we have your credentials you send us before, there is no need to send them again.

    I checked your download history and for this account first version of Appointments+ you downloaded was 1.9.4 - have you used before different account? If I could know that account user name then i could check what was last version you were using.

    kind regards,
    Kasia

  • Chris White
    • Design Lord, Child of Thor

    Hi

    I am not sure if there was an account before. BEcause the only version of the Appointments plugin was the free version.

    We have migrated to the paid Appointments+ version for the 'padding' functionality. Which did appear to be working.

    I think it only stopped when we upgraded from 1.9.4 version. So I presume the padding time was working.

    As we would have 15 minute appointments with 15 minute padding so availability would be

    Appointment 1 12.00 to 12.15
    Padding Time 15 minutes
    Appointment 2 12.30 -12.45

    And so on... NOw as you can see even though we want 15 minute appoinments it is giving us 30 minute appointments.

    I loo forward to this being resolved.

  • Rupok
    • Support Ninja

    Hi Chris White,

    Thanks for your reply. As you said "I think it only stopped when we upgraded from 1.9.4 version", I think it was working on version 1.9.4 on your site. But we could not regenerate the same behavior on 1.9.4 in our test sites.

    However, we have sent all these reports to our developer. We will update you as soon as we get anything from him.

    Please keep in mind, our developers work around the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide an update.

    I will appreciate your patience.

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska
    • Support nomad

    Hello Chris,

    We tested this add-on till version 1.5.4 (which is quite old) and that add-on is not working as you describe. In all versions slots are made longer.
    Even if you take a look on old thread when this add-on was introduced https://premium.wpmudev.org/forums/topic/getting-padding-add-on-and-duration-add-on-to-work-properly you will see that it works the same as now: it creates longer slots when adding padding.
    Is it possible that before you used custom code like this one https://premium.wpmudev.org/forums/topic/appointments-legacy-time-calculus-ignores-padding#post-812510 ? Because it looks like this one does similar thing you require.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.