Padding not reflecting in Add New Appointment in the backoffice

Hello,

I am currently using the Appointments+ plugin to schedule appointments that are 55 minutes in length with 5 minutes of padding after each appointment.

It is currently working in the location where users make the bookings

When I am trying to do so via the Appointments+ dashboard in the admin area in WP, the 5 minutes of padding is not showing up and I cannot schedule appointments properly. See here

Here are my current settings:
General
General Padding resolution
Services