page building troubles

i have to admit i'm getting aggravated trying to build a page. I am limited with the way upfront is setup to do so especially with putting a link from facebook on my site. I'm at the point i will get visual composer to help me build the pages. I hav the header where i want it but the page content is a problem. I hit a snag. i hope you got an answer for this. Thanks David

  • Kasia Swiderska

    Hello David,

    I'm sorry to hear that Upfront is casing you troubles - however I will need more information what is exact issue.

    especially with putting a link from facebook on my site.

    I'm afraid I don't quite understand - what is problem with adding link to your site? I checked your site (one with open access) and there is lots of links in the content inserted, so I'm wondering why there is problem with this one particular.

    I hav the header where i want it but the page content is a problem. I hit a snag.

    Do you mean that you can't move elements in region where content is? I tested that on your site and I could move elements without problem. Please advise.

    kind regards,
    Kasia

  • Rupok

    Hi David,

    this is what i was trying to add to my main page last night

    So sorry to hear the inconvenience you are having. Let us try to fix this for you. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    i am still having troubles with visual composer working with pages after building header with upfront

    Please correct me if I understood it wrong, but have you activated an Upfront Theme on your site, and then trying to edit pages with Visual Composer plugin? Or are you having trouble with the Upfront Visual Editor? Can you please confirm?

    If you are having trouble with the Visual Composer plugin, then I'm afraid, Visual Composer plugin might not work well with Upfront Themes because Upfront is a very complex Theme Framework and Upfront Child Themes are not created like other WordPress themes. It has it's own architecture to facilitate all the amazing features Upfront provides.

    If you are having trouble with Upfront Visual Editor, then can you please try adding the following line in your "wp-config.php" file?
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');
    To edit your "wp-config.php" file, please login to your server with any FTP application like Filezilla and go to the root directory for your site. There you will get this "wp-config.php" file. Open that file, add the line I provided above and save.

    Please confirm here when you are done granting Support Access and also confirm if editor issue is solved with the workaround I provided. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi David,

    Update: I just had an extensive testing with Upfront Themes and Visual Composer plugin. They both play super fine. I didn't face any issue in adding components through Visual Composer in a Upfront Child Theme activated site pages. So if you are having any issue, I think, that is your site specific problem.

    In that case, I'll need to see the issue live and check your site configuration. Please grant us Support Access and confirm here so we can check this soon and resolve these issues as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi David,

    Hope you are doing good today. :slight_smile:

    I checked your websites, and I could see all the links, and the headers are showing in every page that you have configured. It seems like you are still working on your website, and there are incomplete pages, and in terms of functionalities, your theme does seem to work fine. Maybe you can consider adding footer to your website too, by creating a global region.

    Is there anything that we should be looking in particular in your website? Are you looking to run with Visual Composer? Since the plugin is disabled, I wasn't sure where to check, like any specific page that we should be looking at? Please advise, if I'm missing anything here, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.