Page chat - wpmudev-chat.js load problem

Hello there,

we instaled and corectly settuped your chat plugin. Our "page chat" wont load if we are land on that page from another page of that domain.

For example : go on and click on right image to enter page with chat.

If you enter this site directly from everything will get loaded and is working fine.

Already know its conflict with theme. Tried to switch on 2k15 theme and everything works fine.

There is problem that wpmudev-chat.js javacript file wont get loaded.

Can you help us out with this kind of problem? Thanks in advance.


  • Predrag Dubajic
    • Support

    Hey @Jakub,

    Hope you're doing well today :slight_smile:

    Your chat image was linked to /chat/ page instead of /diskusia/chat/
    I have changed the link but I needed to disable W3TC to make it work properly.

    It looks like there is some issue between theme/W3TC/Chat, I would suggest checking W3TC settings, disabling minifying and check other options to see if it will have any affect.

    Best regards,

  • Jakub
    • New Recruit

    Hey @Predrag Dubajic,

    thanks for your previous answer :slight_smile: We already know that its problem related to theme. With another one its working fine.

    To be sure i also disabled W3TC until problem will be solved.

    So can you please help us with this chat loading problem? Any idea how to solve it?


  • Adam Czajczyk
    • Support Gorilla

    Hey Jakub,

    I hope you're well today!

    I took a liberty of accessing your dashboard and change your site's settings. The theme you're using heavily depends on AJAX. The issue here is that the Chat plugin is also depending on AJAX calls. Unfortunately, using "AJAX inside of AJAX" (or "making AJAX calls through AJAX calls") isn't that easy, if possible at all.

    To confirm that I'm on a right path, I've disabled the "AJAX loads" option of your theme for a moment and after refreshing the site a few times in browser (just to get rid of cached items) chat worked.

    The quick workaround here would be to keep "AJAX loads" disabled. To do this, please go to your dashboard's

    "Vzhlad" -> "Theme options" -> "AJAX Settings" page

    and switch the main button to OFF position.

    The better workaround would be to keep AJAX enabled and only exclude this particular page (or plugin) from being loaded via AJAX but I think you may want to contact the theme developer in order to ask how to do it.

    I'm also reporting this as a bug since this affects not only your site but also other sites that may use AJAX-enabled theme or plugins like "Ajaxify WP", however I'm not able to give you any ETA on when this will be fixed.

    I hope that helps and if you have any further questions, I'll be glad to assist!


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.