page has disappeared -tried restoring with snap shot = doesn't work

courses link does not work: http://www.improvingpdhpe.com/courses/

when i clicked on it this morning - it went to a page that said "archive". now it just reloads the home page

I tried restoring via snap shot but nope. the restore doesn't work... it just hangs there.

  • Nastia
    • Support Rock Star

    Hello improvingPDHPE

    I'm sorry to hear you have this issue.

    It looks like your main site doesn't work either for me. There is a "Server Not Found" error when I land on your page.

    To make sure this is not a conflict with another plugin, please run a quick check.

    Please deactivate all your plugins using FTP, or your host’s file manager. Navigate to the /wp-content/ folder. You will see a folder called plugins. Rename the plugins folder to anything that you like. In our example, we will call it “plugins.deactivate”. Once you do this, all of your plugins will be deactivated.

    If the issue was with your plugins, you should be able to see your site. Once you do that, go back to your /wp-content/ directory and rename “plugins.deactivate” back to plugins. Now you can activate one plugin at a time until your site breaks again. At which point, you will know exactly which plugin caused the issue.

    Please let us know how it went!

    Kind Regards,
    Nastia

  • TheBeags
    • Site Builder, Child of Zeus

    Okay so this is what I think happened.

    I activated CoursePress Pro to see if we could use it
    ...It wouldn't work with upfront - so I disabled it after 2 minutes of testing it out

    I think coursepress pro overrode my page because:
    MY COURSE PAGE was improvingpdhpe.com/courses
    ... I am guessing CoursePress Pro's default address is "yoursite.com/courses" too?

    All I want to do is restore my previous courses page before coursepress overrode it.

    I have tried using snapshot to restore it

    but of course it doesn't work.

    And FYI i tried restoring it from the edit page section - via "compare revisions" but my previous page isn't there

    Again, all I want to do is restore my courses sales page.

    It took me 3 hours to build using COPY&PASTE from our old website.
    We have since deleted our old website that had all the sales copy on it (that took me 6 hours to write) --- so I will need to rewrite the whole thing again + spend 3 hours building it again --- which I would prefer not to do.

  • Nastia
    • Support Rock Star

    Hello improvingPDHPE

    I'm glad that you have fixed this issue!

    My apologies for late reply, please note, that multiple posts in a thread it moves in the end of our queue.

    Perhaps the restoring process was interrupted when the Snapshot was restoring files. In case this will happen again, make sure to increase the PHP memory limit and Maximum Upload filesize by putting the following in the wp-config.php file:
    define('WP_MEMORY_LIMIT', '256M');
    And add this lines to the .htaccess file:

    max_execution_time = 180
    upload_max_filesize = 1000M

    Find more information in this article:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    I hope you have a great weekend!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.