Page Layout Change?

I noticed that this site has started to show up with a smaller width on the screen. It should be full width. I am not sure if it was due to some recent plugin updates or not. This is a site I took over and it had a custom theme. I would like some guidance on where to locate the stylings. For example, if you inspect the home page, you will see that there is a max-width property on the body tag. I am having troble locating that styling. Please advise.

  • Nithin
    • Support Wizard

    Hi Clay Hess,

    On checking further, the mentioned CSS is added via WordPress due to the The site is experiencing technical difficulties. error.

    If you view the page source, the CSS is added at the footer, and part of the following:

    <html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">
    <head>
    	<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    	<meta name="viewport" content="width=device-width">
    		<meta name='robots' content='noindex,follow' />
    	<title>WordPress &rsaquo; Error</title>
    	<style type="text/css">
    		html {
    			background: #f1f1f1;
    		}
    		body {
    			background: #fff;
    			color: #444;
    			font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Oxygen-Sans, Ubuntu, Cantarell, "Helvetica Neue", sans-serif;
    			margin: 2em auto;
    			padding: 1em 2em;
    			max-width: 700px;
    			-webkit-box-shadow: 0 1px 3px rgba(0, 0, 0, 0.13);
    			box-shadow: 0 1px 3px rgba(0, 0, 0, 0.13);
    		}

    In general, if there is an error WordPress will try to display The site is experiencing technical difficulties. error screen, however, in your website there seems to be a conflict, and hence the error screen isn't getting displayed properly but the CSS added by the WordPress is making the homepage width small.

    You'll have to enable debug mode, and check what are the related error logs so the homepage displays correctly.

    To enable debug, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );

    After making the above changes, load the homepage, and the related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    You can check the debug.log for more details about the conflict. If the debug.log file doesn't give many clues, then it'll require a plugin conflict test to rule out what's causing the issue.

    Please do let us know how that goes, have a nice day ahead.

    Best Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Clay Hess,

    Thanks for running the conflict test. That's an odd conflict with Smush Pro. This has to do mostly with another enabled plugin or theme causing a conflict with Smush Pro. However, the debug log should have got generated in such use case though.

    I checked your website and could notice the issue occurs when Smush is enabled. Is it okay, if I test further by deactivating all the plugins except Smush Pro to check how the website behaves?

    This would give a better idea on whether the issue occurs once the plugins are activated one-by-one, and see what could be done further.

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Clay Hess,

    Thanks for granting support access, on further troubleshooting, the conflicts seem to be generating from within the theme, and Smush Pro.

    It seems to be a custom theme. Could you please share the copy of the theme, so that I could further test in my test server, and see how it behaves, and check whether there are any workarounds regarding what's causing the issue or not too.

    You can send the link to download the coy of the theme by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    --Link to download the theme (You can use Google Drive, Dropbox etc to share the download link)
    -link back to this thread for reference
    -any other relevant URLs

    Please do follow up on the ticket once you have sent the theme. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Prathamesh Palve
    • Staff

    Hello Clay Hess,

    I went ahead and tested the theme on my lab site which gave the following errors in the debug log:

    [26-Jul-2019 18:02:02 UTC] PHP Fatal error: Uncaught Error: Call to undefined function propslider() in /var/web/site/public_html/wp-content/themes/tandh/footer.php:10
    Stack trace:
    #0 /var/web/site/public_html/wp-includes/template.php(722): require_once()
    #1 /var/web/site/public_html/wp-includes/template.php(671): load_template('/var/web/site/p...', true)
    #2 /var/web/site/public_html/wp-includes/general-template.php(76): locate_template(Array, true)
    #3 /var/web/site/public_html/wp-content/themes/tandh/single.php(34): get_footer()
    #4 /var/web/site/public_html/wp-includes/template-loader.php(78): include('/var/web/site/p...')
    #5 /var/web/site/public_html/wp-blog-header.php(19): require_once('/var/web/site/p...')
    #6 /var/web/site/public_html/index.php(17): require('/var/web/site/p...')
    #7 {main}
    thrown in /var/web/site/public_html/wp-content/themes/tandh/footer.php on line 10

    What I understand is propslider2 is a custom function which isn't defined in the theme side. Most probably it was loaded from the plugin, mu-plugins or some custom code. There is a possibility that you may have removed the plugin or maybe the plugin relating to the code was removed which is why the issue occurred. I went ahead and changed the line in the footer.php to the following:

    <div id="scroller2-wrap">
    <?php if ( function_exists( 'propslider2' ) ) propslider2(); ?>
    </div>

    I added the propslider2 inside the above function as a check. So now propslider2 will only load if it's defined. The function isn't defined in the theme, hence the issue.

    I am also including the footer file in the reply here. You can replace the file by renaming the file to footer.php in your theme folder, clear your site cache and then try to activate the Smush and CDN.
    It should work fine after that. Should you have any doubts or need any help, feel free to reply in the thread here and we would be very happy to help you with it. Have a great day ahead:slight_smile:

    Thanks,
    Prathamesh

    Footer file

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.